Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

It seems like my computer believes that my ctrl and alt key are stuck sometimes. For example, alt+tab will switch applications, ctrl+g opens google desktop search. Sometimes I'll be intending to type a g but instead the google desktop search pops up. If I kill google desktop then I can type a g again, I can also restart google desktop and things are fine. My tab key is still stuck though, i.e. it still thinks I'm holding alt and opens up the application switching dialog instead of actually tabbing.

share|improve this question
    
Is the key physically stuck? Are the keys sticky from a spilled drink or something? Try cleaning out the keyboard with a can of compressed air or removing the key caps and cleaning it with a brush or damp cloth. –  Synetech Jun 3 '11 at 20:56
    
The keys aren't stuck, I've observed the same behavior when I'm docked or undocked. When I'm undocked, I'm using the built-in keyboard, and when I'm docked I'm using a USB keyboard. –  Dave Jun 5 '11 at 20:48
    
Do you have other keyboard related software running like a macro or hotkey program? (Use Autoruns if you’re not sure.) –  Synetech Jun 6 '11 at 4:57
    
@Synetech nope, nothing of the sort... and holy cow.... I don't believe it but Randolph West's solution just worked for me! I just had an occurence when I was typing this reply. –  Dave Jun 6 '11 at 13:02
add comment

5 Answers

up vote 1 down vote accepted

I've seen this behaviour on all versions of Windows since the Start button was invented, and on some machines more than others.

What I normally do is press and release all the keys from Tab to Shift to Ctrl, then the Windows key, then Alt, and then repeat the process backwards, making sure I don't have anything important open.

It usually fixes the problem.


EDIT: It's not StickyKeys that does this.

share|improve this answer
    
Yeah, I see this behavior sometimes too in general, but I've always assumed it was just my keyboard being sticky. The fact that he says they 'act like they're stuck' indicates to me that he's considered that they're stuck, though, so I didn't bother going down that route. :) –  Shinrai Jun 3 '11 at 19:37
    
I'll try this out next time it happens, thanks! The weird thing is that when I kill the application that is assigned to the key, it goes back to acting normally, but other applications, until I kill them as well, still act up. –  Dave Jun 3 '11 at 20:04
    
@Dave, I honestly don't know what causes it, but give my unscientific solution a try and let me know. –  user3463 Jun 3 '11 at 20:51
    
@Dave, of course it “works” when you kill Google Desktop, because when you kill (or even just exit) the program, then the hotkey is no longer reserved. If it still works if when you restart Google Desktop, then something maybe reserving it and thus preventing G.D. from re-registering it again on startup (or maybe that part of G.D. doesn’t handle hotkey registration; that part is handled by something else like a service or shell-extension or something). –  Synetech Jun 3 '11 at 20:55
    
I was just able to try this out. It actually worked! –  Dave Jun 6 '11 at 13:03
show 4 more comments

This can happen with a wireless keyboard. Sometimes the signal from the keyboard can get interrupted at just the right (or wrong) time and a key-up message does not make it to the system, so it thinks the key is still down from the last time it was pressed.

If you are using a wireless keyboard, you can try preventing it by moving the receiver if possible, or the keyboard if not. Also try changing the channel if it supports that. Finally, you can try moving other things that could be interfering with the signal like speakers or metal objects.

As for dealing with the problem when it has already happened, make sure that your keys are being received correctly (just type whatever and confirm that it’s going through), and then press and release the offending “stuck” keys.

share|improve this answer
    
I'm not using a wireless keyboard, just the keyboard integrated into my notebook. Sometimes I'm docked but using a regular USB keyboard. –  Dave Jun 3 '11 at 20:01
add comment

When pressing and depressing a keystroke, windows gets the message first and redistribute the information to applications that requests it, including the focus application, but also third-parties and windows components on the lookout for certain keystrokes. It seems some "Key up" messages does not get through properly in your case.

Here are some wild guesses:

  • Maybe your keyboard's sensors are defective and does not always send a "Key up" signal. Try using an external (regular) USB keyboard for a few hours.
  • Maybe an appplication you have running somehow interrupts keystrokes in a unsupported way and prevents windows from keeping the correct state at all times. Try closing all applications, such as those running in the tray/notification area, and check if the problem is reduced or not.
  • Maybe your system's performance is low, potentially cause timeouts and other delays causing a key state to be ignored or reversed back. Try reducing AERO graphic settings, RAM usage and the number of applications opened.
share|improve this answer
add comment

Possibly you're turning on StickyKeys. To check this:

  • In the Start Menu, type in 'sticky keys'.
  • Click on the search result that says 'Change how your keyboard works'.
  • Make sure 'Turn on Sticky Keys' is unchecked. (You can also click through to set it up more specifically.)
share|improve this answer
    
Sticky keys is not turned on. –  Dave Jun 3 '11 at 20:01
add comment

My solution: I got different results from hitting the Ctrl and Alt keys at the right (rather than the left) side of the keyboard.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.