Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Host: Windows XP Pro SP3. Client Windows 7.

On the host I have a directory that's shared. While it's technically writable I never do so. Under it are some folders into which volumes have been mounted. (This exposes all the volumes while only using up one drive letter.)

The original stuff worked after some struggle but now I'm trying to add another couple of folders. They show up fine on the client but the client sees them as read-only. Since the whole purpose of this exercise is backup that's utterly useless.

I've tried recreating the share, no change.

This isn't a reporting illusion, the folders really are read-only. Any attempt to create a file in them from the Windows 7 machine fails.


It's just workgroup sharing. I'm the only user, this is just drive space for backups, nothing fancy.

I just tried writing to the top level directory, it worked. The subdirectories have the "Inherit from parent the permission entries that apply to child objects" box checked. Examining the effective rights for one of the offending subdirectories shows EVERY user on the box can write to it.

I think it must somehow be connected to the fact that these subdirectories have volumes mounted in them.

Stranger and stranger: I created a share on one of the offending directories and it also shows up as read-only on the client!

share|improve this question

migrated from Jun 3 '11 at 19:06

This question came from our site for system and network administrators.

How are you mounting the folders? – Nixphoe May 30 '11 at 1:25
@Nixphoe: Volumes mounted in subdirectories through disk management. – Loren Pechtel May 30 '11 at 5:08
Have you checked the permissions on the folders? What are the share permissions? (NTFS and Share permissions are completely separate and the union least privileged of them applies). – Chris S Jun 3 '11 at 18:31

I don't know why it is like this since it has never made sense to me, but I believe I know what you are talking about, and the answer is that despite being able to add things, rename a directory, when you are in Windows Explorer, right-click on a directory, it ALWAYS says "read only".

Forget the share for a moment, open your C-drive, and right click a directory/folder (pick a small one to test the following on) will say "Read-only". Uncheck "Read-only" and apply. Open it again...still "Read-only". It NEVER changes.

The same thing on network/shared drives. It is one of those strange things that I have learned to ignore.

share|improve this answer
Basically it is like this because there is no functional "read-only" attribute for folders. – syneticon-dj May 29 '11 at 20:42
No, it's really read-only. I can't create a file in the problematic folders. It's only the share, though, on the machine itself I can create stuff fine. – Loren Pechtel May 29 '11 at 23:51
There can a difference between read only and not having the permission to write. The net effect can be similar, but technically different. You do not say if you have domain-level security or if you are just sharing between two workgroup computers, but you should be looking at security and inheritance next. Make sure your user has permissions to write at the top level you want him to have access to, and then check to make sure the subdirectories have the advance setting "Include inheritable permissions from this object's parent" checked. That may vary slightly on XP, but there is similar. – KCotreau May 30 '11 at 2:02
See the original message – Loren Pechtel May 30 '11 at 5:07
up vote 1 down vote accepted

It looks like I found my own answer. It seems that the problem is with setting permissions on a drive mounted in a folder.

When I examined the permissions while it was mounted everything looked right but in order to get things to work I simply put it on a drive letter--and the permissions were now wrong! I fixed them and put it back into it's folder and everything is working fine.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .