Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I connect my wired Xbox 360 controller to a USB port on my PC, the computer shuts down instantly. I have no idea why this happens. It used to work.

I have tried to other ports, and I can connect my 2 matcatz fightsticks fine.

share|improve this question
    
Make sure you have disabled the automatically restart on system failure "feature"( see for example : pcsupport.about.com/od/windows7/ht/… ). Side note: when XP first came out Microsoft and their sock puppets said they got rid of those annoying blue screens. That's because (by default) they made the computer shut down instead of showing them. –  horatio Jun 3 '11 at 21:17
    
ok, i was getting a blue screen of death. i get this stop messege, dont know if it helps. STOP: 0x0000007e (0x0000000000000000, x0FFFFF880031A89C8, 0xFFFFF880031A8230 –  neil1 Jun 4 '11 at 8:56
    
no indication of a module? –  horatio Jun 7 '11 at 13:44
    
Probably not your problem, but related: support.microsoft.com/kb/327863 –  horatio Jun 7 '11 at 13:47

1 Answer 1

  • Follow the steps in this article

  • Try installing a new copy of the driver here

  • Try connecting the controller into a different device. If it shutsdown that device, it might be a short in the controller. If it doesn't, you might not have enough power on the USB bus to power everything. In the latter case, unplug some unused devices on your PC before plugging in the controller.

share|improve this answer
    
ok it works on my laptop. but i have a 850W PSU on my pc, so could that really be the issue? –  neil1 Jun 3 '11 at 19:38
    
Probably not, since I see a lot of people complaining about similar issues. Is it XP ? If so, SP2 or SP3 ? Can you check the system events? Does your computer power off or restart ? –  Code Bling Jun 3 '11 at 19:42
1  
In other news, what on earth are you doing with an 850W PSU!? Do you have 5 video cards and 20 cores? –  Code Bling Jun 3 '11 at 19:43
    
im on windows 7 64bit –  neil1 Jun 3 '11 at 19:46
    
tried installing 64bit drivers but i got 'setup error: not enough storage', i have 15GB free –  neil1 Jun 3 '11 at 19:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.