Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

First of all I'd like to say I've read topics but I have not been able to find an answer. I've had a power cut and when my PC with Windows 7 64-bit (12Gb RAM / Core i7) reboot, I've lost my perfectly working Internet connection. Now there's an "unknown network = Public network" instead. I've tried several things and this stuff really drives me nuts:

I've tried:

  • to uncheck IPv6 because I've read somewhere that IPv6 may mess everything (sometimes). No success.
  • to turn off network discovery. No success.
  • to uninstall (not disable, uninstall) my network card so that it's re-detected. No success
  • to remove the Admin password = no password for admin. No success
  • try to set default gateway but no success
  • the only solution that may work is by using gpedit.msc but, of course, it's not available for the Windows 7 home edition

I'm using my laptop with Ubuntu on it: absolutely no problem at all. This really drives me nuts. This is the first time in 15 years of computing that Ubuntu is better than Microsoft. Does this mean something? I've paid to upgrade from XP to Vista (because, as a Web developer I needed to test my websites with IE9). Vista was such a crap that I gave up and I paid once again $135 to upgrade to Seven home edition. And now I can't access Internet only because of a lack of intelligence of the team who created Seven (the network part to the least).

My network configuration is simple:

  • My "big" PC which is connected to the "Internet Box" with Ethernet cable (I avoid Wi-Fi when I can)
  • My laptop which is connected to the "Internet Box" with Ethernet cable too
  • The Box with Internet access that acts like a switch too (=4 Ethernet plugs for local network)

So :

(Internet) <=> FreeBox (local IP
                ^  ^
                |  |
                |  +-- laptop Ubuntu (inet adr:
                +----- big PC with Windows 7 (see further for IP config)

I've tried to config "by hand" the IP config ("" with default gateway "" and DNS "". No success = "unknown network")

Any idea how to solve my problem?

Here's my ipconfig /ALL

Configuration IP de Windows

   Nom de l'hôte . . . . . . . . . . : PC-de-Olivier
   Suffixe DNS principal . . . . . . : 
   Type de noeud. . . . . . . . . .  : Hybride
   Routage IP activé . . . . . . . . : Non
   Proxy WINS activé . . . . . . . . : Non

Carte Ethernet Connexion au réseau local :

   Suffixe DNS propre à la connexion. . . : 
   Description. . . . . . . . . . . . . . : Connexion réseau Intel(R) 82567LF-2 Gigabit
   Adresse physique . . . . . . . . . . . : 00-22-68-66-FA-C6
   DHCP activé. . . . . . . . . . . . . . : Oui
   Configuration automatique activée. . . : Oui
   Adresse d'autoconfiguration IPv4 . . . :éféré) 
   Masque de sous-réseau. . . . . . . . . :
   Passerelle par défaut. . . . . . . . . : 
   NetBIOS sur Tcpip. . . . . . . . . . . : Activé

Carte Tunnel isatap.{D2E5CF40-E064-4B8F-AD6F-806141104266} :

   Statut du média. . . . . . . . . . . . : Média déconnecté
   Suffixe DNS propre à la connexion. . . : 
   Description. . . . . . . . . . . . . . : Carte Microsoft ISATAP
   Adresse physique . . . . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP activé. . . . . . . . . . . . . . : Non
   Configuration automatique activée. . . : Oui

Carte Tunnel Teredo Tunneling Pseudo-Interface :

   Statut du média. . . . . . . . . . . . : Média déconnecté
   Suffixe DNS propre à la connexion. . . : 
   Description. . . . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Adresse physique . . . . . . . . . . . : 00-00-00-00-00
share|improve this question

4 Answers 4

up vote 1 down vote accepted

Ok I've tried almost everything, but the problem seems not to come from Windows 7. The big problem that was the stupid behavior of Windows 7: if I say "hey there's a DHCP" and it can't connect to the "DHCP Server", it should say that somewhere but it doesn't. Instead, it just "supposes" the network card works properly (which is not the case), and says it has detected a "Public network". It will never be able to connect to this "Public network" because the network card doesn't work properly. Anyway that was really confusing, because it was like saying "hey man I found a network, it works, but I can't connect to it so I guess this is a Public network"... So the simplest solution I've come so far is: boot on the Ubuntu Desktop Live ISO.

  • If DHCP discovery works, it's clearly a 100% Windows problem.
  • If it doesn't it's a hardware problem.

That was a lot faster than re-installing the whole Windows 7 upgrade stuff and re-installing all my software... just to discover this was a hardware problem and Windows 7 had given very bad clues about what was going wrong.

There should be a Wizard in Seven that could ask:

  • "Are you a basic user?"
  • "Are you an advanced user?"

If we answer "2", then "Do you know how to read advanced network diagnostic?"

  • Yes
  • No

If we say "Yes" then "Here's the detailed diagnostic: DHCP discovery has failed" and tada! Problem solved.

share|improve this answer

Your question leads me to believe that you might be connecting directly to the Internet. You will always get unknown in that case. If so, to really make sure this does not happen to you all the time, you should have a local router/firewall with a switch with a few ports. You would then have a local LAN, something like 192.168.1.X.

If your Internet goes down, you have not lost your connection to the local network, and you would just reboot your cable modem (or similar) and router, if necessary.

I have been using Windows 7 since it came out. This is not a Windows problem, but it is hard to direct you further without seeing your network. You should really post your ipconfig/all results if you need more help.

Also, when you loconnectionnnection, just try opening an command box, and going ipconfig /release , then ipconfig /renew.

share|improve this answer
I guess this is a 100% Windows Seven Problem otherwise I couldn't write here, with my nice and perfectly working Ubuntu laptop which is connected to the same network. Thanks for the hint, I'll modify my question to be more precise. –  Olivier Pons Jun 3 '11 at 21:02
OK, be arrogant. It sounds like a USER setup problem to me. The fact that Windows 7 does thing differently than Ubuntu is irrelevant since Ubuntu is not as wide-spread in corporate environments. Windows 7 tries to differentiate between a domain environment, home environment, and public one so it can help set security for home users, who don't know much. If you are connected directly to the Internet, point the finger inward and ditch the attitude. Post your ipconfig /all and I will be able to tell you a lot more. –  KCotreau Jun 3 '11 at 21:08
I'm sorry if my comment sounds "arrogant". I'm just really annoyed (and I'm trying hard to stay polite when I write "annoyed") with a problem that should not appear, because it did not exist with XP. So it seems to me it's not "progress" it's "regression". And what really gets on my nerves is that my laptop work so nicely whereas the laptop itself cost less ($300) than the price of the 2 upgrades I've paid for XP => Vista then Vista => Seven. –  Olivier Pons Jun 3 '11 at 21:17
I hope that my description is better now, and I'm really sorry to talk that way, but, I hope you agree with me, loosing 8 hours for something like that is not normal at all. –  Olivier Pons Jun 3 '11 at 21:22

OK, now that you have posted your ipconfig, I see that you are using an internal network, which is good.

This is the big problem: 1) Do you you have a DHCP server set up? Right now, you are getting a 169.x.x.x address, which means that Windows is not getting an IP address either set statically or from DHCP. It gave one to itself...it is called a local link, or automatic private addressing. It is to talk to other computers local to it that have no configuration either.

Make sure your network driver is up-to-date. Make sure your netmask is You can test by pinging If you get no reply, your network card is not set up correctly. Then ping your internal default gateway of Your NIC could also just have died.

Once you have that, you can set a domain in your DHCP server options of mydomain.local. If you are using a static IP address, go to the IPv4 settings>advanced>DNS settings and enter mydomain.local into the Append these DNS Suffixes. It is more for Windows server domains, but it should allow your network to identify itself.

share|improve this answer
Thank you very (very) much indeed for your answer. –  Olivier Pons Jun 3 '11 at 21:33
I am trying. It comes down to you not having an IP address on your network 192.168.1.x (easy to fix) or your NIC not being able to communicate due to bad hardware or driver (can be a little harder to fix). I have to go feed my daughter...will check back later. –  KCotreau Jun 3 '11 at 21:35
Thank you very (very) much indeed for your answer. ping works. Ping does not work. The DHCP works, because my laptop if configured to get its IP from the DCHP server. And the DHCP server is the FreeBox (I've re-checked that it's "on", and the valid IP addresses distribution are between and –  Olivier Pons Jun 3 '11 at 21:38
IT may be working, but you are not getting an IP address if your IP is still 169.x.x.x.. Try manually configuring the following settings: IP address, netmask, gateway, DNS (google public DNS). Now see if you can ping (yourself), then ping (your laptop per the config above, if no firewall enabled), then ping (your gateway), then ping (a random AT&T server on the Internet I use. If you get that far, you have perfect connectivity, and all that is left is to check DNS. Ping www.cisco.com. –  KCotreau Jun 3 '11 at 21:54
Post back the results. –  KCotreau Jun 3 '11 at 21:54

Try this, delete your network locations, then set up a new network connection.

Click the Icon for the unknown network in Network and Sharing Center, then choose "Merge or Delete Network Locations", highlight all the connections and select delete.

. enter image description here


This ip config below means Windows could not reach the dns server, so it assigns an internal network address. Since Ubuntu works, see what DNS server Ubuntu is using, compare it to the manual ip config you did in Windows, which showed it as, they should match, next try to ping the DNS server while in Windows.

See this page, try resetting your TCPIP stack, then reboot. How to reinstall the TCP/IP protocol driver on Windows 7?éféré) Masque de sous-réseau. . . . . . . . . : 255.255.0.

share|improve this answer
I've tried this. Nope. I had 3 "not active" connexions ("Local", "Local2" and "MMS"), I've deleted them all... and nothing: it still tries to connect, and detect only "unknown network = Public network" –  Olivier Pons Jun 3 '11 at 20:54
I hope that my description is better now, and thanks again for you suggestion even though is doesn't work :'( –  Olivier Pons Jun 3 '11 at 21:23
Did you try to set up a connection manually? "set up a new connection or ntwork" –  Moab Jun 3 '11 at 23:26
Yep I tried (I've updated my question according 7 hours ago) –  Olivier Pons Jun 4 '11 at 7:46
See edit 2 above –  Moab Jun 4 '11 at 14:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.