Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there a setting in VLC to change default audio output to 5.1?

share|improve this question
1  
I guess if the source is not in 5.1 you'll have to find software that emulates 5.1 output from a stereo signal. Could be your audio driver can do that. –  slhck Jun 4 '11 at 16:16

7 Answers 7

up vote 15 down vote accepted

I felt the need to resurrect this as it’s pretty high up on search results and the solution no longer works for v2.0.2—however, I finally found a fix!

  1. Press Ctrl+P to bring up preferences.
  2. At the bottom of the right-hand navigation select the All radio-button under the Show settings area (bottom left of the interface).
  3. Now expand the Audio tree, select Out Modules and select DirectX.
  4. Select your "Output device" and "Speaker configuration" from the drop down menus.
  5. Restart VLC.
share|improve this answer
    
Best answer. This was working for me. –  joctee Oct 8 '12 at 11:46

This was a bit confusing for me as well. I have 7.1 audio on my system. VLC always defaulted to stereo audio. Then I finally figured it out. You must have your sound cards speaker configuration set to 5.1 or else VLC will not choose the 5.1 track. I thought that 7.1 set for speaker configuration on my sound card would work for anything so the system would play 5.1 or 7.1 if available. But apparently with VLC, and maybe some other programs, your system must match exactly or it will not recognize your settings. This is a feature that the VideoLan team needs to fix. With the advent of 7.1 audio VLC needs to recognize that it can play 5.1 audio on a 7.1 system.

share|improve this answer

From vlc --longhelp --advanced:

  --force-dolby-surround {0 (Auto), 1 (On), 2 (Off)}
                             Force detection of Dolby Surround

There's also the respective setting in the GUI version of the settings under "Audio->Effects->Dolby Surround". Is has the options "Auto", "On" and "Off".

From what I understand, it should automatically detect whether the source media is surround sound or not.

share|improve this answer
    
As far as I can tell, this is a setting that changes whether DS/DTS should be used in the audio channel, but not the line configurati on (stereo, left+right, 5.1....) –  dadver Jun 11 '11 at 8:40
    
Okay, then this answer is probably not what you're looking for. Sorry! –  Victor Jun 11 '11 at 10:53

Only if your audio format is dts/dolby digital 5.1, the 5.1 channel could activated in VLC. If the original file is of only stereo type, the 5.1 option will not get highlighted in the above said menu. You try using SURCODE DTS and Gold wave software for converting a stereo file into user defined 5.1 DTS file.

share|improve this answer

open VLC> go to preferences> select all mode in the bottom left corner> select audio> find stereo audio output mode> select Dolby Digital Surround at bottom of list. As of 2.1.5 VLC.

share|improve this answer

Much better solution if you want to respect the audio mapping produced by VLC:

  • Using DirectX as explained above in the solution would give an audio mapping like this :

    Stereo audio file:

    main debug: using audio filter module "scaletempo"
    main debug: conversion: 'f32l'->'f32l' 48000 Hz->48000 Hz Stereo->Stereo
    main debug: conversion pipeline complete
    main debug: conversion: 'f32l'->'f32l' 48000 Hz->48000 Hz Stereo->3F2R/LFE
    main debug: looking for audio converter module matching "any": 12 candidates
    main debug: using audio converter module "trivial_channel_mixer"
    main debug: conversion pipeline complete
    

    5.1 audio file:

    main debug: using audio filter module "scaletempo"
    main debug: conversion: 'a52 '->'f32l' 48000 Hz->48000 Hz 3F2R/LFE->3F2R/LFE
    main debug: looking for audio converter module matching "any": 12 candidates
    main debug: no audio converter modules matched
    main debug: looking for audio converter module matching "any": 12 candidates
    main debug: using audio converter module "a52tofloat32"
    main debug: conversion pipeline complete
    main debug: conversion: 'f32l'->'f32l' 48000 Hz->48000 Hz 3F2R/LFE->3F2R/LFE
    main debug: conversion pipeline complete
    
  • Using WaveOut as i'll describe respect better the audio mapping for stereo content and keep the same mapping as the first solution :

    Stereo audio file:

    main debug: using audio filter module "scaletempo"
    main debug: conversion: 'f32l'->'f32l' 48000 Hz->48000 Hz Stereo->Stereo
    main debug: conversion pipeline complete
    main debug: conversion: 'f32l'->'f32l' 48000 Hz->48000 Hz Stereo->Stereo
    main debug: conversion pipeline complete
    

    5.1 audio file:

    main debug: using audio filter module "scaletempo"
    main debug: conversion: 'a52 '->'f32l' 48000 Hz->48000 Hz 3F2R/LFE->3F2R/LFE
    main debug: looking for audio converter module matching "any": 12 candidates
    main debug: no audio converter modules matched
    main debug: looking for audio converter module matching "any": 12 candidates
    main debug: using audio converter module "a52tofloat32"
    main debug: conversion pipeline complete
    main debug: conversion: 'f32l'->'f32l' 48000 Hz->48000 Hz 3F2R/LFE->3F2R/LFE
    main debug: conversion pipeline complete
    

Now if someone feel this workaround as a proper solution, you can do it like this :

  1. Press Ctrl+P to bring up preferences.
  2. Go to "Audio" on left (or on top if VLC 3.0.x)
  3. In output, set output module to 'WaveOut audio output', no need to change your speaker configuration as the first solution.
  4. Restart VLC

Hope that will be helpful for someone...

share|improve this answer

"open VLC> go to preferences> select all mode in the bottom left corner> select audio> find stereo audio output mode> select Dolby Digital Surround at bottom of list. As of 2.1.5 VLC." FIXED for me ! 10+

share|improve this answer
1  
This is just a copy of Blankman's answer so will be deleted. Please read the faq. Thanks. –  Arjan May 17 at 9:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.