Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm working on a program to detect viruses, so I downloaded some virus samples, but when I copy or delete or read contents of those files in my program, Windows 7 always stop that and make a beep sound.I've turn off all the protections I can found, including Windows Defender, Firewall, UAC. And there is no anti-virus software in my system. I'm already the Administrator. What should I do?

share|improve this question
add comment

2 Answers 2

Turn off UAC. It should be prompting you every time you run those virus samples.

Open User Accounts by clicking the Start button , clicking Control Panel, clicking User Accounts and Family Safety (or clicking User Accounts, if you are connected to a network domain), and then clicking User Accounts.

Click Turn User Account Control on or off. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

Select the Use User Account Control (UAC) to help protect your computer check box to turn on UAC, or clear the check box to turn off UAC, and then click OK.

Turn off DEP. Open System by clicking the Start button, clicking Control Panel, clicking System and Maintenance, and then clicking System.

Click Advanced System Settings. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

Under Performance, click Settings.

Click the Data Execution Prevention tab, and then click Turn on DEP for all programs and services except those I select. Then select the virus samples you're using

share|improve this answer
    
I've turn off UAC..forgot to say that.. –  wong2 Jun 4 '11 at 18:35
    
Then select the virus samples you're using when I do this, it said that I can't open it.. –  wong2 Jun 4 '11 at 18:39
add comment

You say you've already turned off all security systems, but you don't list User Access Control, which is the system responsible for the security popups. Have you turned that off as well? You should find the settings under Control Panel/User Accounts.

Also, try running your anti-virus software as administrator. That way, you've already given it all the privileges it needs, so you won't have to confirm every time. Easiest way to do this is to right-click the icon/executable of your program, and choose "Run as administrator". If you start a command prompt with administrator privileges, all programs started from that command prompt are also given those privileges.

share|improve this answer
    
I've turn off UAC..forgot to say that.. –  wong2 Jun 4 '11 at 18:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.