Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I get this error if I try to activate my 2-month-old Windows installation.

  • I have tried restoring default registry permissions and other things as officially directed by Microsoft - no change.
  • I have tried adding Network Service permissions on the whole Registry/HKU - no change.
  • The computer is not joined to a domain.
  • Plug and Play and Software Protection services are running OK.
  • I am using perfect Windows 7 keys which work everywhere else.
  • I have tried using an elevated command prompt for the slui command - nothing changes.
  • slmgr /ato in an elevated command prompt gives me the same:

0x80070005 acccess denied.

slmgr /dli says:

Line 1333 char 5 permissions denied.

  • I am doing everything as admin and elevated
  • I can not run system repair from the CD since my system is encrypted using 3rd-party encryption software.

This should not be happening. I am using TrueCrypt for full system encryption. I have always used it and everything has always been OK on other installations - the Windows activation mechanism as well as all other programs do not even ever detect that they are all in an encrypted environment. It's always been transparent.

share|improve this question

migrated from stackoverflow.com Jun 4 '11 at 19:41

This question came from our site for professional and enthusiast programmers.

    
"I can not do any system repair from CD since my system is encrypted using 3rd party soft" - could this be part of the problem? –  Paul Nearney Jun 4 '11 at 19:41
    
to add info to your question, use the edit link under your question; don't add it as an answer. If you register your account, you will be able to log in and get access to any questions you ask. –  nhinkle Jun 4 '11 at 20:21
add comment

2 Answers

I have a couple suggestions. First, I would talk to your encryption provider. It may be that this is the cause of your issue.

If this doesn't work or this isn't the issue, contact Microsoft and open a case with them. They will be able to help you out and since it is an activation issue they should do it for free.

share|improve this answer
add comment

Truecrypt recommends that you activate before encrypting. I tested the theory a while back in a VM. Activating an unencrypted XP, Vista, or 7 install works, then after encrypting it stays activated. But sometimes if you encrypt before activating, it will fail. Try decrypting the disk, activating, then re-encrypting the disk. It will take a while, but it may be your only option if a restore is out of the question. Just make sure you set the encryption software to wipe free space during the re-encryption.

share|improve this answer
    
But thats exactly what I did. As usuall, I have installed windows 7, all the updates and activated. I have encrypted it all after that. After 1.5 month, all of a sudden it started asking me about the activation..... –  Carlito Jun 5 '11 at 11:08
    
In that case, try running sfc /scannow from inside Windows (regular or safe mode) with the install disc in the DVD drive. If you have whole-drive encryption rather than partition encryption, you may be able to enter the "Repair Windows" mode from the Windows Boot Manager after authenticating with the encryption software's bootloader. –  TuxRug Jun 5 '11 at 22:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.