Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed a twicked version of Windows 7 (xDark Deluxe v4.2 64-bit) and I am absolutely loving it. It is faster than I anything I've ever seen and no complaints until now...

I want to save a System Image as I did with the OEM version, in the Control Panel's Windows Backup and Restore, but when I click in "Create System Image, I get an alert box saying:
"The backup application could not start due to an internal error:
The service cannot be started, either because it's disabled or because it has no enabled devices associated with it.(0x80070422)."

I have searched Google and got this from support.Microsoft.com:
I. Volume Shadow Copy (VSS) - "Manual" ii. Microsoft Software Shadow Copy Provider (SWPRV) - "Manual" iii. Remote Procedure Call (RPCSS) - "Automatic" iv. COM+ Event System (eventsystem) - "Manual" & "Automatic" v. System Event Notification Service (sens) - "Automatic" vi. Windows Backup – “Manual”

I have setup Windows Services like this, I have rebooted my computer, made show those settings were still right, but I still get the same error.

Can someone please tell me how to fix this?

share|improve this question

closed as too localized by Synetech, nhinkle Jun 6 '11 at 5:15

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
What’s “twicked Windows 7… xDark Deluxe”? Googling it can only find a cracked, pirated version of Windows 7 with a theme and some settings pre-set. If that’s the one you’re talking about, then you should probably ask for help from the cracking/piracy location from which you got it (maybe this xDark person since (s)he should know it well). –  Synetech Jun 5 '11 at 1:39
    
thank you very very much for your judgement. although i don't feel the need to explain myself, i have a paid licence of windows 7 so i feel very much in the right to use this one, since I'm not a "Super User" like you, and i don't know how to theme and pre-set mine as well as these guys did. But again, thank you (and it's tweeked i meant, sorry for my bad english) –  André Alçada Padez Jun 5 '11 at 1:59
    
Have you scanned the system for Malware? –  Moab Jun 5 '11 at 2:08
    
@André what judgement? You asked for help with it, and since I have never heard of an “xDark” version, I Googled it to find out what the differences are from a normal version (you do realize that the differences are what are causing your problems right?) The only thing I could find about this so-called “xDark” version was a pirated copy. I never “judged” you, I just said that if you were talking about that version, then you should ask them for help since they’re the ones that modified it and know what has been changed. –  Synetech Jun 5 '11 at 19:07
    
Besides, if you are using a hacked version, then you can’t ask here (especially if it is a pirated copy, whether you own a key or not), since it’s “too localized” to a small group of people who have a specific, non-standard, version of the software that could change at any time. I’ve seen them shut down questions for much less. You can’t expect us to know, and I doubt many people here will bother to find out what a cracker did. –  Synetech Jun 5 '11 at 19:12

3 Answers 3

up vote 3 down vote accepted

From what I can tell, xDark’s release of Windows 7 has been first updated (though it’s probably long out-of-date by now), then specifically set to disable updates to prevent de-activation. If you have an NFO file from it, you should read over to see the extensive list of modifications that have been made to it.

A quick scan indicates that you’d need to at a minimum re-enable the Windows Update and BITS services to get Windows to be able to update again and hopefully fix any errors by replacing any hacked files, but there may be other, deeper (eg registry) changes that are preventing it from working. The backup service was probably disabled as well, so you’ll have to enable and run the backup service as well (sometimes a service demands to be set to automatic, simply being set to manual and even running is not enough). For that matter, check if the backup service even exists anymore. In fact, this page recommends resetting several services to fix backup.

(On the page from the first Google result, one person even complained about there being too many things disabled.) I can’t find any point of contact with this “xDark”, and have not heard of him in “the scene”, so you may have to ask other people who have used his release.

Try running the system-file-checker: sfc /scannow.

The description for v4.3 mentions over 500 DLLs have been modified (ie, not just setting changes, but actual file hacks, which I believe violate the terms-of-use). I for one would not be comfortable using such a hacked version from an unknown source; I’d rather install a clean, reliable copy, then use a program like The Ultimate Windows Tweaker to apply a few tweaks myself. Then adjust the services as needed, as well as the startup programs and such. Finally, when I’ve got it the way I like, I would clone the drive so that if I want/need to, I can restore the whole thing, with all of my changes without having to reinstall or make them again.

share|improve this answer
    
thanks, for all your help and good will :) –  André Alçada Padez Jun 6 '11 at 17:54

You are not running services that are required to run this. Take a look at the Microsoft Fix for this

  1. Click Start Start button type Notepad in the Start Search box, and then click Notepad in the Programs list.
  2. Copy the following text, and then paste the text into Notepad: http://pastebin.com/4NcGZAc1 (Click to view the stuff to paste in)
  3. Click File, click Save As, and then type Repair.bat.
  4. In the Save as type box, click All Files (.).
  5. In the Save in box, click Desktop, and then click Save.
  6. On the File menu, click Exit.
  7. Right -click the Repair.bat file that you saved in step 5, and then click Run as administrator. This action starts the required services.

(Taken from the Microsoft Support Fix)

This fix is originally for getting updates from Windows Update, but it is the same error code.

share|improve this answer
    
thanx, i've been to that page, but moved on because my problem was different. Anyway, i just tried this solution now, and i still get the same feedback. If it helps, when i run the batch, i get this problem: C:\> sc config DcomLaunch start= auto [SC] OpenService Failed 5: Access is denied. and in the end C:\>net start DcomLaunch The requested service has already been started. Is this related? –  André Alçada Padez Jun 4 '11 at 22:46
    
actually fixing the the backup service needs several different services to be reset to fix that error code. –  Synetech Jun 6 '11 at 5:09

Install a full legal version of Windows 7 from official installation media. Then you should be able to run a backup just fine. Super User is not a support forum for illegal software which has been modified beyond all recognition. If you still have the problem after installing a clean version of Windows, then come back and re-ask your question.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.