Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For programs using the GTK 2.16 interface, GTK automatically chooses the language for common items according to system settings, and when the language is right-to-left it automatically flips the interface so that it looks right-to-left. Unfortunately this is not good for programs that were written to appear in left-to-right English language.

What can I do to make gtk2 interface left-to-right? In another words I don't want GTK detect my language, I want to set it to English. I don't want it to automatically flip the programs' interfaces.

share|improve this question

Setting the LANG environment variable seems to help. Either open a CMD, do set lang=en and then run the app (from within this CMD), or change the environment variable via the Control Panel (for all apps).

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .