Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to get some visual styles working completely on my computer.

They say I need to patch some files, install the theme, and to get the style working 100%, I also need to replace explorer.exe, shell32.dll, and a few other files.

The problem is, when I do this, after restarting, the computer gives a shell32.dll is missing error and won't load. I have restored my computer to a working state, but that's not the problem. The problem is I want the visual style to work completely, all bells and custom start button included.

If this is a duplicate(I couldn't find a question similar to this on Google or Super User with an answer), please link me in a comment.

share|improve this question
    
ok, so I figured it out. I booted into safe mode, did all the regular steps, and now it works. this is a nice theme. smiley face. –  Blue Jun 5 '11 at 9:16
add comment

3 Answers

If the visual style operates by hacking the shell, and the hack failed, it's unlikely that it's going to work on your computer. My guess is that whatever custom theme you're using is built for x86 and you're running x64, or vice versa.

Either way, what you're doing is not supported by Windows. You'll have to contact whoever built the theme and ask why their hack is not working.

share|improve this answer
    
bummer, because it was the 64 bit dlls and exe that I was copying over. –  Blue Jun 5 '11 at 7:57
    
@Blue: Just copying them over shouldn't work. The system has access control lists by default set to prevent exactly what you tried to do -- replacing system files with unsupported versions. It's possible to override but it's more than just "copy this over"... you'd have to remove the TrustedInstaller permissions. Really, any kind of modification like this is a bad idea. You really want to give whomever supposedly wrote that theme complete control over your computer? Because the shell is one of the programs that can take over the Secure Desktop (and the machine) quite easily. –  Billy ONeal Jun 5 '11 at 7:59
    
yes, I know it's dangerous, but I want to install the themes completely anyway, and yes, I did do the permissions thing and replaced the files. And that's when windows get's all bummy at me and gives the error(after I restart of course). –  Blue Jun 5 '11 at 8:06
    
@Blue: Yes. It's Windows' fault that you replaced the shell binaries and the replacements don't work. Oh wait. –  Billy ONeal Jun 5 '11 at 8:07
    
That's not what I'm talking about, isn't this supposed to be a place for people who play around with their computers? –  Blue Jun 5 '11 at 8:12
show 7 more comments

I have never faced any problems (Windows 7, 64-bit) when trying many of the themes that require such replacements. However, I can still think of a few things you can try:

Make sure your archiving program is 64-bit. If not, it will end up extracting the files into the virtual storage folder SysWOW64 instead of System32. I recommend 7-Zip. If you cannot obtain a 64-bit version of your archiving program, extract the files to another folder (Desktop works best), and copy them using Windows Explorer.

In the off-chance that this fails as well, or if you do not want to risk compromising your system, you can also use something like Anolis Resourcer to extract the relevant resources from the patched system files, and add them to your versions. This may also reduce incompatibilities with Service Packs or other updates between your computer and the theme author's computer.

share|improve this answer
    
edit, this is going to bea bit confusing.= using anolis. –  Blue Jun 5 '11 at 8:35
add comment

Have you tried the Uxtheme Multi Patcher?, usually works for me.

share|improve this answer
    
Yes, I've already patched my system. The problem is when I want to complete the theme by changing the start button, folder icons, etc. I have to replace files, and that results in problems. –  Blue Jun 5 '11 at 8:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.