Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I would like to use HDMI on my graphic card for audio output. ALSA shows it as a card with 4 devices and I can get sound through one of them (the other three are different channels, perhaps? I have only stereo output connected). Although Pulseaudio has the right card set as default, it seems to me that it plays on a wrong device. Pacmd shows that the sink has parameter alsa.device set to the first device listed by ALSA, but I can get sound only from the second one.

How can I force Pulseaudio to use another device of the same card as a default output?

Or how can I force ALSA to switch numbers of the first and the second device on the card?

share|improve this question
up vote 4 down vote accepted

It seems like I found a solution, at least for this particular case. Since I knew the card and device number assigned by ALSA, I just had to open /etc/pulse/default.pa. in editor and change this line

#load-module module-alsa-sink

into this

load-module module-alsa-sink device=hw:2,7

where 2 and 7 are my particular instances of card and device numbers. This created a new sink connected to the correct device, which was then used as the default output.

share|improve this answer

PulseAudio Device Chooser (padevchooser)?

share|improve this answer
    
Unfortunately, padevchooser needs name of the sink to connect to, but the device I want to use is not available among Pulseaudio sinks. I would have to create it first, or modify the one with different alsa.device parameter. Both things lie beyond the bounds of my current knowledge and abilities. – pomotron Jun 5 '11 at 19:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .