Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a problem with my router and powerline adapter, for some reason my router and powerline adapter assign odd IP addresses to me network devices, but not all of them and not all the time:/ You see normally my IP addresses start with 192.168.0.x and I've got a reservation table so all my devices get the same address each time they log in , but my router and powerline adapter just gave my Dad's iPad an address that was something like 169.254.x.y cant remember the other two digits, What could the reason be for this?

The router is a Netgear DG834GT and the powerline adapter is an AV 200, model is XAVN2001

share|improve this question
    
Are the router and the powerline adapter two separate devices or one? –  grawity Jun 5 '11 at 13:36
    
the router is seperate from the powerline, eg the powerline takes internet from the router transmits it through the powerline of my house to an emitting station that i plug into the wall and then emits a wireless signal with with its own SSID(and ip address on the network) but the router as its default gateway, so essentially its a fancy range booster :P –  andrewktmeikle Jun 5 '11 at 23:01

3 Answers 3

169.254.0.0/16 is the IPv4 link-local address range (also called in Windows "Automatic Priviate IP Address" or APIPA). These addresses are not assigned by DHCP but automatically generated by the device. If you get a IPv4LL address, it usually means that your iPad cannot find the DHCP server for some reason.

If this happens with all devices, it might mean that your network is too unreliable. (You could test packet loss using ping or mtr.)

share|improve this answer
    
na it doesnt happen with all my devices just some. What i meant to say was that i have an address reservation list on my router so that each router gets assigned the IP adrress that the reservation tells it to, like my laptop is 192.168.0.21 normally, eg now, but earlier on it could 169.254.x.y and when i did ipconfig beside ipv4 it had "automated", so does that mean it couldnt get an IP address so it just gave a automatic one? –  andrewktmeikle Jun 5 '11 at 22:51
    
@andrew: Yes, that's exactly what it means. –  grawity Jun 5 '11 at 23:03
    
so why would it not be able to get an IP address? Would the 'preferred' address have to be taken by another device? –  andrewktmeikle Jun 8 '11 at 9:47
    
@andrew: No, if the preferred address was taken your device would simply request another address from DHCP. If you get a 169.254 address, it almost always means there was no DHCP response at all. I can suggest starting Wireshark on one of the problematic computers and repeatedly renewing the DHCP lease (ipconfig /renew or dhcpcd -n <interface>), to take a look at the actual requests being sent. Also, if the router runs Linux, you can use tshark or tcpdump to see if those requests reach the router. –  grawity Jun 8 '11 at 11:03
    
Alright cool, ill give it a shot. Its a bit disturbing that their was no response from the dhcp at all :/ what can the cause of that be? heavy network traffic? –  andrewktmeikle Jun 8 '11 at 15:45

Your router did not give you that 169.254.x.x address, your iPad did. It is because you are not really connecting to your network.

You either have a physical hardware problem, driver-not-correct issue, or a network configuration issue. Most likely a network configuration issue.

Make sure the SSID and password are typed correctly. Both are case sensitive. Make sure that you have the same type of encryption.

Also, check to make sure that if your wireless router has an access list, you add the iPad's MAC address to the list of accepted devices. It is under your wireless setting>Wireless Station Access List. If it has "Turn Access Control On" checked, you must add the MAC address to that list.

share|improve this answer
    
These addresses are not Windows-specific (the question mentioned an iPad). –  grawity Jun 5 '11 at 13:46
    
grawity, fixed, but the answer stays the same. –  KCotreau Jun 5 '11 at 14:08
    
Yeah, i thought that - mentioned that in the reply further down. But if it was driver not correct issue it wouldnt be a sporadic issue, it would be a consistent issue. Like as of just now, its back on the internet with the DHCP assigning it the correct address based on its mac address whereas before it was getting assigned the automatic one(169 etc). It did however have trouble connecting to the network once i told it to "forget" it. My xbox360 had the same issue, the day before, but as of now is working again, not changing any settings anywhere.. :/ im aware they arent specific, just example –  andrewktmeikle Jun 5 '11 at 23:03

It's definitely sure that DHCP can't traverse the Access Point → powerline → router. I have the same issue. Only fix was to set up DHCP on the AP (router) and it would work with two different networks, e.g. 192.168.1.x at internet router and 192.168.0.x at Wireless Access Point.

But that sucks too, as the two networks won't talk to each other for file sharing and the like.

I just ended up grabbing a WiFi extender instead of using powerline adapters.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.