Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Belkin F5D7230-4 router, and I don't have many problems with it, however one thing which has always bugged me is that its admin page is accessible locally via two locations: 192.168.2.1 and my IP address (e.g. 76.216.174.73). If I am at the library, etc. I cannot access it at all, and that's fine because if I really need to, I can use an SSH tunnel.

My issue is that I can access it at my remote IP address while on my local network. I would like to only be able to get to it by 192.168.2.1 while within my local network. This is because if I'm writing a script which connects to my server, I have to use 127.0.0.1 or 192.168.2.1, but before distributing must switch it to my external IP address (or my no-ip address.) Is there anyway to prevent my remote IP address from resolving to the router's admin page while I am on the local network (that is, connected directly to the router by ethernet cable or wifi), and instead have it forward me to the correct computer and port as it normally would if I were not on the local network?

I've looked through the Belkin settings and haven't been able to find anything.

Thanks.

share|improve this question
    
So to be clear, the sitution that you are trying to fix is that when you are inside your network, you would like for your external IP to point to your computer rather than the router, correct? –  Kirk Jun 5 '11 at 18:08
    
What version of the router? –  KCotreau Jun 5 '11 at 18:08
    
Kirk, I also have no idea what the question is. I thought it was that he does not want to be able to access the router externally. –  KCotreau Jun 5 '11 at 18:09
    
Yes, Kirk. When I am on my network, I would like visiting my external IP address to point to the computer defined in the port forwarding section, as it would if I were outside of the network. –  John Jun 5 '11 at 18:09
    
I am not able to access the router's administration page externally, and I don't want to be able to. Firmware version 4.03.03, boot version 2.01.03. –  John Jun 5 '11 at 18:10

2 Answers 2

up vote 3 down vote accepted

When this problem is encountered on a router, the most common fix is to 'move' the router's admin port off 80 and onto something else so that NAT will then handle inbound requests properly, and port forwarding will take them to the designated device on the LAN. See whether your router allows you to change the admin interface port - for example, here's my Draytek:

enter image description here

share|improve this answer
    
While this does not work for me as a) I don't have the option to, and b) only the HTTP management port exists and if I try to ssh to myself using my remote IP it fails, this is probably the best answer out there. Thank you. –  John Jun 6 '11 at 19:37

For example, let's say my laptop is set to 192.168.2.3, and my server is on 192.168.2.4, running Apache on port 80. If I go to my external IP (for example, 76.216.174.73), it takes me to 192.168.2.1 on port 80 (which is the router's admin page,) instead of 192.168.2.4 on port 80 (the Apache server.) If I visited my external IP (76.216.174.73) from the library, my router would connect me to 192.168.2.4 on port 80. I would like this to happen while I am at home, instead of just at the library, a cafe, or friend's house. Is that clear?

FINALLY, I understand the question, but unfortunately, there is no solution using most firewalls/routers, and doubtful there are any home models. The issue at hand is Network Address Translation, and there is a specific name for this problem, but I just can't remember right now: Basically, what it means, is that internally, you have to access resources by the internal IP address.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.