Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Ubuntu (11.04) on a triboot machine, and I'm trying to boot the XP partition at /dev/sda1 using VirtualBox.

I've run

VBoxManage internalcommands createrawvmdk -filename sda.vmdk -rawdisk /dev/sda

clicked Use existing hard disk in VirtualBox and selected sda.vmdk, but then it throws the following error:

Failed to open the hard disk /home/a930913/sda.vmdk.
The medium '/home/a930913/sda.vmdk' can't be used as the requested device type.

with details

Result Code: 
NS_ERROR_FAILURE (0x80004005)
IMedium {9edda847-1279-4b0a-9af7-9d66251ccc18}
IVirtualBox {d2de270c-1d4b-4c9e-843f-bbb9b47269ff}

Help on booting my XP partition inside Ubuntu please.

EDIT: Turned out it needed to be run as root. Now I get this when I boot it up:

enter image description here

share|improve this question
up vote 2 down vote accepted

Turned out it needed to be run as root

Run as root is not need, just append self into 'disk' group and relogin. About error on boot XP: reboot to XP and set 'Standart IDE controller' in device manager 4 u IDE controller, also u can set 'Stadart VGA controller' 4 u videocard (create new hardware profile may be a good idea). In VirtualBox mashine properties enable 'Use IOAPIC' option.

Good luck!

share|improve this answer
I didn't find how to set the Device Manager stuff, but ticking the Use IO APIC option did the trick. Thanks! – 930913 Jun 16 '11 at 5:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.