Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Formatting an external 500GB HDD took almost >6 hours that I started like:

D:\>format /FS:fat32 F:
The type of the file system is EXFAT.
The new file system is FAT32.
Enter current volume label for drive F: musix

Proceed with Format (Y/N)? y
Formatting 476810M

finally responded with the error:

The volume is too big for FAT32.

However according to MSFT there are no such limitations. (I used XP specs, while I am formatting in Win7, ok?) I am not formatting the drive during setup but on an installed version from the command prompt.

I want to use this disk with the maximum available capacity as en external HardDrive connected to an MDI interdface in my car to play music.

What are the proper settings for that and can I use/format the (almost) full 500GB?

share|improve this question
How large are your clusters? If your clusters are 32kb, then you max out at 8TB. If your clusters are 4 kb, I would assume you max out at 1TB, etc – soandos Jun 6 '11 at 6:43
I do not know ;) clustersize is not my cup of tea, I formatted using default settings, but should they be much larger? – Caspar Kleijne Jun 6 '11 at 6:49
Windows XP can mount and support FAT32 volumes larger than 32 GB (subject to the other limits), but you cannot create a FAT32 volume larger than 32 GB by using the Format tool during Setup. If you need to format a volume that is larger than 32 GB, use the NTFS file system to format it. – soandos Jun 6 '11 at 6:50
Clusters cannot be bigger than 64kb in FAT32 – soandos Jun 6 '11 at 6:51
Any reason for reformatting away from exFAT? exFAT is a viable alternative to FAT32 on Vista and Win7 for large drives and goes beyond the limitations of FAT32, just be aware that Windows XP requires a download from Microsoft and Linux support may be patchy. – Mokubai Jun 6 '11 at 7:39
up vote 6 down vote accepted

You cannot format a FAT32 volume greater than 32Gig from XP or Win7 but you can mount and use a bigger one.

However you must use an alternate tool to format the volume.

There are limitations as to bootable drives on your greater than 32gig Fat32 drive

Partition Tool

Also read this guys page for more technical info.

share|improve this answer
DON'T USE the partition tool in the link of this answer. It installs, shows advertisements, opens, but doesn't do provide the "free" service it promises, but tries to make you buy a full license in stead. – nl-x Jun 17 '14 at 15:33
At the time this question was answered it didn't do all the things that you say. But ultimately ,"all succumb to the might need for dollars". – kingchris Jun 18 '14 at 7:04
And generally i wouldnt mind. But come on... make me pay premium for just formatting a drive once? Messed up. Btw does linux do this without a hassle? – nl-x Jun 18 '14 at 7:10
I have never tried to format a FAT32 partition via Linux but it is suppose to be possible according to Google. But as always run your disk tools, copy a whole bunch of files across. verify their CRC or MD5 or byte by byte compare. Defrag drive then compare files again. Let the User Beware. – kingchris Jun 18 '14 at 7:28
as aditional infomation it doesnt allow filer over 4GB :) as i know – Francisco Tapia Sep 2 '15 at 14:44

What an annoying limitation! You can't format FAT32 volumes larger than 32GB from any version of Windows...

C:\Users\jeff>format e: /FS:fat32 /Q
Insert new disk for drive E:
and press ENTER when ready...
The type of the file system is EXFAT.
The new file system is FAT32.
QuickFormatting 58.9 GB
The volume is too big for FAT32.
Format failed.

... but they must exist because this Lexar USB 64GB drive right here is formatted FAT32! How?

It is possible to do it, you just have to use some other tool. I used this one, FAT32 Format.

enter image description here

share|improve this answer
For some reason I had trouble re-formatting a 64GB drive that was formatted to 32GB, I had to use DISKPART at the command line as indicated here: – Jeff Atwood Apr 13 '13 at 18:07
Great answer! It worked for me! – mathreader Jul 1 at 20:40

You can format your external hard drive in FAT32 using SwissKnife (freeware). It will let you bypass The volume is too big for FAT32 error.

share|improve this answer
note that unfortunately has become an adware magnet.. the install process has literally 5 different "declines" you must issue to not get adware with your download :( – Jeff Atwood Dec 19 '12 at 21:09
Official site. – Karan Dec 24 '12 at 22:11
@Jeff: Thanks for the feedback. Their official page only publishes the premium version. Those who want to download the free version may google for "swissknife free windows 7". That search brings download sites like tucows, softonic, etc. but I have no idea if they are adware magnets. – Mehper C. Palavuzlar Dec 25 '12 at 6:09

Rufus can do this. Start it up, then

  1. choose File system Large FAT32
  2. uncheck Create a bootable disk
  3. uncheck Create extended label and icon files
  4. click Start

Source code is available at GitHub

share|improve this answer

It doesnt help when you want to use the maximum available capacity, but for those of you who need a fat32 disk under 32GB what I did was setup the primary partition as under 32GB.

Run these steps/commands
1. Open command prompt as administrator 
2. Diskpart
3. List disk
4. Select disk X (where x is the disk you want to partition/format)
5. Clean
6. Create partition primary size=30000   (where 30,000 is the size in MB you want the partition to be, under 32GB)
7. Select partition 1
8. Active
9. Format quick fs=Fat32
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .