Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been running Ubuntu 10.10 on my HTPC for a while now without any issues. But wanting to make things as cable free as possible I have bought a TP-Link TL-WN951N wireless card - based on the AR5008 chipset. The problem with this card is that it is intermittently recognized at boot time.

Approximatively 2 out of 3 boots fail to see any wireless interfaces. Every time this happens, "lsmod" reports ath9k as being loaded and used, "lspci" lists my wireless card correctly - but all of the user space utilities fail to "see" or use the card: ifconfig / iwlist / iwconfig / rfkill / network manager etc.

Subsequent reboots will fix this issue "magically".

There is absolutely nothing useful in the logs - no errors, nothing - because the system does load the driver but somehow doesn't manage to use it.

I have tried stopping irqbalance - thought it was an irq mess up somewhere. Upgraded the kernel, tried to the latest ath9k from source, tried to pass the option of "no hardware encryption" to the module (the only option available) - nothing solved the problem.

Have any of you encountered a similar problem? Any ideas on what else to try or what to do to get more verbose debugging of the problem?


share|improve this question
I'm seeing this now on Ubuntu 12.10 64-bit. I have this card. lscpi shows a difference between working/non working though: "Ethernet controller [0200]: Atheros Communications Inc. AR5008 Wireless Network Adapter [168c:ff1d] (rev 01)" vs "Network controller: Atheros Communications Inc. AR922X Wireless Network Adapter (rev 01)" –  Pat L Jan 18 '13 at 10:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.