Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A small background. I've just subscribed to virtual dedicated server running Fedora 14. But before starting to setup it, I've decided that it is a good idea to try all installing/configuration on my own local VM. So I downloaded a Fedora 14 Netinstall CD and used latest VirtualBox to install it (leaving NAT for network configuration).

The problem itself. It seemed that installation ran fine (it asked configuration for eth0 and worked well with DHCP as an option). Shortly I discovered that my "yum" isn't working. After googling around I found different suggestions - uncommenting base urls in fedora.repo and fedora-update.repo. I've added a google/yahoo DNS servers and disabled ipv6 module. It didn't help. But after messing around I've found out that I can't ping any server by IP. "ifconfig" does not output eth0 at all just a lo. I opened /etc/sysconfig/network-scripts/ifcfg-eth0, but it looked just as one desribed here http://docs.fedoraproject.org/en-US/Fedora/14/html/Deployment_Guide/s1-dhcp-configuring-client.html . I've even tried using VMWare Fusion 3.1. (I'm running Mac OS X as a host if it's relevant) instead of VirtualBox.

I'll try to configure it using bridge connection. But right now I ran out of ideas. I've decided to write here only after several hours of configuration and reinstalls.

Thank you for your attention.

share|improve this question

migrated from stackoverflow.com Jun 6 '11 at 10:30

This question came from our site for professional and enthusiast programmers.

1  
ifconfig will only show interfaces that are "up". If you try ifconfig -a you should see it, or give it an IP and it'll appear. You can try running "dhclient eth0" manually to grab an address. Also try "dmesg" and look for network card messages about the addresses on boot. –  Sirex Jun 6 '11 at 10:32
1  
+1 Sirex - I have used Fedora in virtualbox and it 'just works' so there's something up with the NIC definition - worth seeing what dmesg says (as Sirex mentioned) and perhaps changing the NIC type in the virtualbox settings to see if another type works better. –  Linker3000 Jun 6 '11 at 11:06

1 Answer 1

The root of the problem was that Fedora didn't fireup eth0. I entered the following command and it worked:

sudo /sbin/chkconfig --level 35 network on
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.