Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After a recent archlinux upgrade via pacman -Suy I lost UTF-8 display in terminals under xorg. This affects lxterminal, XFCE's terminal, and kde's konsole. I use XFCE 4.6 as window manager.

In my /etc/rc.conf I do have the line LOCALE="en_US.UTF-8" but non-ascii characters still show in terminal as funny symbols. UTF-8 characters are displayed fine in virutal consoles (accessible via ctr+alt+f1..) and in SSH sessions via putty. Also gnome-terminal displays UTF-8 without problems.

Is there a way to fix it?

share|improve this question
1  
What exactly do they look like? If you type printf '\xe2\x99\xaa\n'; does it output "" or "♪" or ""? –  grawity Jun 6 '11 at 21:05
    
The second, i.e. "�". –  ccpizza Jun 7 '11 at 10:00
add comment

1 Answer 1

I got my UTF-8 console back after renaming my ~/.config folder, and also looking through the pacman update logs (/var/log/pacman.log) and merging the .pacnew files mentioned in the 'warning' lines.

share|improve this answer
    
but if you rename the .config directory don't you lost all your old configuration? –  tokland Aug 10 '11 at 13:41
    
2tokland: yes, you lose some config settings, but since I had not deleted the folder but renamed it, I could copy over the customized files which I needed. Anyway, most config files under ~/.config are generic and seldom contain anything important. –  ccpizza Nov 13 '11 at 23:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.