Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Following an upgrade from XP to Win7, my external card reader is no longer working.

I've tried the answer here and have Googled around for a solution. Unfortunately, the consistent answer seems to be to install new drivers, and I can't because it's a generic cheapo card reader and I've no idea what the manufacturer and model are.

Are there some generic drivers I can get from somewhere? I tried uninstalling the driver that Windows provided from the device manager and reconnecting the hardware, allowing it to download fresh drivers but still it's not working and although you can plug it in and the light comes on, the drives do not show under Computer.

share|improve this question

3 Answers 3

up vote 3 down vote accepted

I can't quite believe this is all it was, or which bright spark at MS chose it to be a default setting, but I found this link and the solution is:

"Go to Start -> Computer -> Organize -> Folder and search options -> click View tab -> uncheck "Hide empty drives in the Computer folder" -> OK"

I can't quite believe it. How's a non-techy user supposed to figure that one out with a brand new SD card that'll never show up to give them the option to use it? And I'm a techy myself and it took a shedload of Googling and resorting to posting on here to find the answer. Usability?!

share|improve this answer
2  
Welcome to Windows 7. –  Moab Jun 6 '11 at 21:51

It is possible that Windows is simply hiding the drives because there aren't any media in them. I know this is typical behavior in Windows 7 and you can change it, however I believe it is the default. Try inserting an SD card (or something that it should be able to read) and see if it is recognized. What should happen is the drive should appear in My Computer and you should be able to see the files.

The setting that controls this behavior is under Folder Options, under the View tab. There is a checkbox under the hidden files and folders radio buttons labelled "Hide empty drives in the Computer folder". It is likely checked on your Windows 7 installation.

If it is unchecked, or inserting a card doesn't do anything, you'll want to see if the drives are listed in Device Manager. If they are and they report errors, let us know what they are. If they don't show up, try rescanning for hardware changes (there's a toolbar button under Device Manager that does it). If it still doesn't show up, it could simply be defective.

I would place my bet on the fact that the drives are simply hidden since they don't have any media inserted in them yet, though, and that the device itself works fine.

share|improve this answer
    
I'm afraid not. They show up in the device manager with no errors, and I've inserted an SD card and it still doesn't show up. The red led to indicate access even comes on but it's just not playing. –  bcmcfc Jun 6 '11 at 20:09

You can try using the Unknown Device Identifier to find the drivers for that device.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.