Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In my .emacs I set up the following code to allow me to use biblatex cite commands when editing LaTeX files:

    (setq reftex-cite-format 
      '(
        (\C-m . "\\cite[]{%l}")
        (?p . "\\parencite[]{%l}")
        (?t . "\\textcite[]{%l}")))

But it has had no effect. It still seems to be defaulting to the set of cite commands I had set previously with M-x customize-variable. Why? And how do I get emacs to recognise the change? I have tried restarting emacs...

share|improve this question

As indicated by http://tex.stackexchange.com/a/31992/5701 you may have to set the variable inside (eval-after-load 'reftex-vars)`. This is just a guess and I notice that it might be bad practice.

(eval-after-load 'reftex-vars
  '(progn
     (setq reftex-cite-format
           '((\C-m . "\\cite[]{%l}")
             (?p . "\\parencite[]{%l}")
             (?t . "\\textcite[]{%l}")))))
share|improve this answer

Just a guess, but at the end of my .emacs file is a custom-set-variables block which is written to when I use M-x customize-variable. Maybe yours is the same, and your changes to reftex-cite-format are being overwritten by this?

share|improve this answer
    
Yeah I thought of that. I didn't see anything setting reftex-cite-format in the custom-set-variables block and putting the above code at the very end of my .emacs doesn't make a difference. – Seamus Jun 10 '11 at 12:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .