Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have many different types of files in a folder - .php, .css, .htm, .js, .docx, .xls, etc.

The only file type that Windows (viewed from Windows Explorer) actually shows the extension are the .php files.

Why is this?

share|improve this question

3 Answers 3

Two things are most likely on your system for this to happen:

  1. The option Hide extensions for known file types is checked.

  2. You haven't registered the PHP filetype to your system and thus is an unrecognised file format.

These combined will show .php file extensions while other documents are hidden.

You can change this when you open a folder and go to: Tools > Options > View

There you'll see the option to uncheck Hide extensions for known file types. Do so and save.

If you want to hide the PHP file extensions, leave the extensions option hidden and just register the filetype.

share|improve this answer
    
It is a library computer. For what ever reason I guess Windows automatically has those filetypes registered but not PHP. That's PHP discrimination! –  user73919 Jun 7 '11 at 20:40
1  
Windows doesn't handle PHP files by default. Usually only gets added if you're doing some web dev. Looks like you won't be able to configure the system settings if the computer is locked down. @chr –  random Jun 7 '11 at 21:38

Look at one of the PHP file properties from explorer.
Maybe its called filename.php.php !!

You seem to have your filename extensions visibility set to hidden.
But, that does not work when you have the extension two times.

share|improve this answer

You might have to change the properties of folders. By default windows hides extensions of known files.

Under Control Panel -> Folder option -> View tab, uncheck the "Hide extensions for known file types" box

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.