Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I don't know how Google determines my location; it automatically switches to use google.com.hk. Both google.cn and google.com.hk are inaccessible to me in China, so I want to ensure I always use google.com as the default search site.

I've set the Google language to English, but it doesn't seem to work.

I've also added a custom search rule in Chrome: http://www.google.com/?q=%s as default - however, this will open the google.com starting page whose search input box is filled with the keywords, but is waiting to be clicked to show the search result.

share|improve this question

closed as off topic by Dennis, DragonLord, Paul, Dave M, ChrisF Feb 9 '13 at 23:45

Questions on Super User are expected to relate to computer software or computer hardware within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
See webapps.stackexchange.com/questions/4667/… and related questions on the Web Applications site –  ChrisF Jun 7 '11 at 8:07
add comment

5 Answers

up vote 12 down vote accepted

Change the default search engine base URL from google.com.hk to google.com in Chrome's Settings (available from Chrome Menu → Settings → Manage Search Engines). Alternatively you could type chrome://settings/searchEngines in the omnibar to reach that destination.

share|improve this answer
1  
In the preference page, the default google search engine URL is: {google:baseURL}search?{google:RLZ}{google:acceptedSuggestion}{google:originalQ‌​ueryForSuggestion}sourceid=chrome&ie={inputEncoding}&q=%s, unfortunately simple replace won't work here. –  Xiè Jìléi Jun 7 '11 at 9:04
4  
Got it! I should replace {google:baseURL} to http://www.google.com/. –  Xiè Jìléi Jun 7 '11 at 9:06
2  
If you do this you will lose the ability for chrome to suggest terms visiting /ncr once fixes the problem permanently (or until you clear cookies) –  Matthew Dolman Oct 4 '12 at 0:08
    
{google:baseURL}... is not editable. –  kilaka Jun 15 '13 at 21:30
    
@kilaka Just delete the uneditable one and make a new one. –  user371699 Jun 28 '13 at 15:35
show 2 more comments

First do as in the other answer and go to the Search Engines editor. The quickest way is to Right-click on the Search Bar.

You cannot, however edit the default "google.com.xx" entry since the URL part is grayed out. It looks like this:

{google:baseURL}search?{google:RLZ}{google:acceptedSuggestion}{google:originalQueryForSuggestion}{google:searchFieldtrialParameter}{google:instantFieldTrialGroupParameter}sourceid=chrome&ie={inputEncoding}&q=%s

What you can do is to create a new entry below, call it "My Google" or something, give it any keyword, and enter as the URL string the same string, substituting the {google:baseURL} part with google.com or whichever domain of Google you want.

www.google.com/search?{google:RLZ}{google:acceptedSuggestion}{google:originalQueryForSuggestion}{google:searchFieldtrialParameter}{google:instantFieldTrialGroupParameter}sourceid=chrome&ie={inputEncoding}&q=%s

Then mouse over it, and hit "Make Default".

(Google changes this every so often on Chrome, so you probably want to grab the latest on the original/built-in search entry, and just update the google:baseURL part).

share|improve this answer
add comment

Click on the following link to disable Google country specific redirection. Do NOT click the link if you don't want it disabled, as you will have to delete your Google cookies to re-enable it.

http://www.google.com/ncr

share|improve this answer
    
does this work for the search? From the phrasing of the question I think this is the built in search bar in Chrome, rather than the google page. –  tombull89 Jun 7 '11 at 7:52
2  
this is actually the correct answer. The two ones mentioning changing the google base url are bad as you lose the chrome suggest phrase feature. –  Matthew Dolman Oct 4 '12 at 0:07
add comment

I had the same problem here in Bangkok. Being from the USA I want my search results to display in English and I had my HTC One X set to English and I tried the www.google.com/ncr which worked for everything but the omnibox search results which displayed results in part English and part Thai.

I fixed it by going down to the bottom of the search results page and clicked on Settings (which was displayed in Thai so I had to translate) and there I changed all the language settings to English (the list was also in Thai so I had to translate). After saving the changes future pages were displayed in English.

The omnibox still shows www.google.co.th/search... but the search results display in English.

This will not help those that need the search to be in .com but does help others like myself.

share|improve this answer
add comment

I know it is an old thread, but this worked for me:

Go to the search engines editor. Click on 'manage search engines'. Mark the Google entry and change the address to google.com. Then right-click the grayed-out entry and select 'inspect element'. Now the developer tools window will open at the bottom, and the line for this feature will be marked. The last word in the line should read 'disabled'. Double-click this word, which will mark it. Now you can delete it and press enter. This should enable you to enter the greyed-out field in the Google entry above. You will now be able to replace (copy from here and paste there) the contents with

https://www.google.com/search?{google:RLZ}{google:acceptedSuggestion}{google:originalQ‌​ueryForSuggestion}sourceid=chrome&ie={inputEncoding}&q=%s

(Change 'https' to 'http', if you don't want the secure protocol.)

Finally press ENTER, and it should be fixed. You should now be able to search on google.com - it worked for me, and maybe it will work for you as well...

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.