Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a 2.9GB MKV file, unzipped from a .RAR archive, that causes explorer.exe to take up 100% CPU when I select it by single clicking. Also, when I attempt to copy and paste it, the copy dialog hangs on the "Discovering files" phase until I end the process. It is also the only video file in the folder that lacks a thumbnail image from the video; it is simply a VLC icon. However, it plays normally in the player.

I suspect somehow the file info got corrupted and Windows keeps trying to read it, but I don't know how or why, or how to fix it. I downloaded it again from the source and extracted it again, didn't fix it. After moving via cut and paste (which took unusually long), the problem persists. I would think the size would not be an issue, as it is neither the largest nor the smallest file in the directory.

Any help would be appreciated.

share|improve this question
    
I have the same problem. Don't think it's a file corruption. I've ran Process Explorer and looks like it has to do with a DVIX Device module. The only way to delete the file is by CMD Line –  user203416 Mar 1 '13 at 16:21

1 Answer 1

My hunch is that it has to do with thumbnail generation. Try renaming the file. You can also try deleting the thumbs.db file in that directory (it is marked as both hidden and system) and see if it clears up a corrupted thumbnail. Or install the K-Lite Codec Pack and disable thumbnail generation for .mkv during the install.

Note that there are a lot of weird rules for thumbnail generation, including not generating for files greater than a certain size in addition to files by type (i.e. .mkv) and by location (i.e. local hard disk or network server). K-Lite gives you access to some of these settings during install.

share|improve this answer
    
I thought it might be something about the thumbnail generation but I wasn't sure. I've tried renaming it to no avail, and there is no thumbs.db file in the directory. I have "show hidden files" enabled, and I also have unchecked "hide system files". thumbs.db exists in other directories but not this one. –  Jeremy Jun 7 '11 at 17:22
    
@Jeremy It sounds like a problem with the source file itself. An easy fix is to encode the video file again. –  Ramhound Jun 7 '11 at 18:09
    
"Easy" in terms of procedure, not time. =P –  Alex Hirzel Jun 7 '11 at 18:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.