Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have set up a WiFi router to share my internet connection. My ISP is such that when I first try to open a site after connecting through the wifi network, it presents the ISP's login page. After I login, I can surf normally.

When I connect a second laptop to the wifi network, it connects successfully. However when I try to open any site on it, the whole ISP login thingie kicks off again. Now the problem is that after I login to the ISP on the second laptop, the internet connection on 1st one stops working. In a nutshell, I can use internet on any one machine at a time (although I can successfully connect to the wifi network).

Now my question is whether I have screwed up the settings on my router or is it a problem on my ISP's end?

share|improve this question
    
Maybe you should just call your ISP. They would know if it is caused by them. –  KCotreau Jun 7 '11 at 18:23

4 Answers 4

up vote 1 down vote accepted

Turn on NAT on your router. Most web-based login (a.k.a. "captive portal") schemes key off of what the network sees as your client's MAC address or IP address. If you enable NAT on your router, only the router's MAC address and IP address can be seen by the rest of your network.

It sounds like right now your "router" is just acting as a simple bridge between your clients and your broadband connection, so the ISP network is able to see the various MAC addresses and IP addresses of your clients.

Some Wi-Fi routers don't let your turn NAT off, because it's always enabled between the LAN ports and the WAN port. If that's the case with your router, you probably have one of your router's LAN ports plugged into the broadband modemupstream ISP connection. Instead, you should plug your router's WAN port into your broadband modemupstream ISP connection.

share|improve this answer
    
I don't know much about networking but you seem to be hitting the right notes. :) NAT is disabled on my router and the mode is set as "Bridge" for all the 4 LAN and 1 WAN port. There is no modem though. The cable is directly plugged in the WAN port. Please advise what should I do next. –  Mayank Jun 7 '11 at 18:41
    
@Mayank When I said "to the broadband modem", I suppose I should have said "to whatever your upstream ISP link is". Sounds like you have it hooked up right, now you just need to enable NAT. –  Spiff Jun 7 '11 at 20:11
    
I looked everywhere on the router page but couldn't find how to enable NAT. Pointers will be appreciated. –  Mayank Jun 8 '11 at 4:47
    
@Mayank Here are a list of possible near-synonyms for "NAT" that you should be looking for: "NAPT", "PAT", "Internet Connection Sharing", "Address sharing", "IP masquerading" (IPmasq), "Share a single IP address", "share a public IP address". If that didn't help, you'll probably have to tell me the make, model, hardware revision, and firmware version of your router, so I could look for the relevant manual online. Or if you can find the correct version of the manual online yourself, and just post the URL here, that would be even better. –  Spiff Jun 8 '11 at 5:18
    
You were dead right. After changing the mode from "Bridge" to "Router" and enabling NAT, it is working absolutely fine. Many thanks. –  Mayank Jun 8 '11 at 12:38

This sounds like a very unusual arrangement. I'm used to ADSL where the router/modem handles the authentication transparently for all connected PC's regardless of whether they use HTTP at all. The authentication you describe sounds more like the system used at Internet cafes. I believe some WiFi routers support this (for people who share WiFi access with customers or friends).

Perhaps your ISP is storing authentication-state in a client-side session cookie? In which case your second login probably invalidates the cookie stored at the first PC.

It is possible your ISP's T&C's prohibit multiple PC's (perhaps they charge more for more simultaneously connected PCs)

I'd call the ISP helpdesk.

For more specific answers, try updating your question with the name & location of the ISP.

share|improve this answer

Some ISP's only allow one PC to connect, call your ISP to confirm this. You may have to pay more for a second PC to access the internet.

A way around this is to share your internet connection on one PC with the second, in Windows is is called ICS, Internet Connection Sharing.

share|improve this answer

You should be able to login to your ISP with your router.

Login to your router and fill in all the credentials there, this way your router will be constantly connected to the internet allowing any computer that connects to it to have access to the internet without any trouble.

share|improve this answer
    
"You should be able to login to your ISP with your router." Please explain how. –  Mayank Jun 7 '11 at 15:34
    
@Mayank When you connect to your router, you can choose the connection type which should allow you to enter the credentials of you ISP. This is usually located under the Basic Setup/Internet Setup of your router. –  Greg Jun 7 '11 at 15:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.