Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For some reason IE9 does not store browser history. The problem has existed ever since I upgraded. Despite resetting the IE settings, the problem persists. I do not have "Delete browsing history on exit" checked and my "Days to keep pages in history" is set to 20.

All I get is something like this:

enter image description here

share|improve this question
    
Have a look at your history folder while you are browsing, and see if anything pops up. Then you'll at least know if the problem is that your history is being deleted somehow, or if IE is not recording it at all in the first place. –  Cam Jackson Jun 23 '11 at 5:54
add comment

6 Answers

up vote 2 down vote accepted

In your Internet Options have you set it to "Delete Browsing history on exit"? Make sure that is unchecked.

Also in the Browsing history settings how many days have been set to keep history? (Default is 20 if I remember correctly.)

share|improve this answer
    
Hi Josh, thanks for the reply. Sorry, I should have included that I do not have "Delete browsing history on exit" checked and my "Days to keep pages in history" is set to 20. –  Kamal Jun 9 '11 at 15:59
    
@Kamal, did you once have the beta and then upgraded to release? If so I would try completely removing IE and re-installing it. –  Windos Jun 9 '11 at 19:56
add comment

I've been experiencing this problem and solved it recently. The problem seems to be caused by the index.dat file growing beyond a 16MB limitation. Once it grows past that size, IE seems to no longer write additional information to it. Although the following article is talking about the index.dat file used for IE's caching mechanism, it seems highly plausible that it's what also causes the history problem.

See here for more information

This issue occurs when the Index.dat file in the following folder reaches a size of 16187392 bytes

Removing the file has allowed my history to be to logged as normal. Below are the steps required to delete the file.

Firstly, you'll need to open up a command prompt with administrative rights. So, assuming Windows 7:

  1. Click the Windows icon to open your start menu.
  2. In the search box, type: cmd
  3. At the top of the list should be cmd.exe. Right-click it and select Run as administrator.
  4. Press Yes from User Account Control if it pops up asking you if you'd like to run it.

You need to run it as an administrator so you have the necessary permissions to delete the file. Steps to delete the file:

  1. Use the following command to change to the directory with the index.dat file:

    cd %USERPROFILE%\AppData\Local\Microsoft\Windows\History\Low\History.IE5

  2. You'll need to close the browser in order to delete the file, so to get back here quickly, copy the URL to this question before closing the browser.

  3. Run the following command: del index.dat /a:s

del is the command to delete a file. Appending /a:s to the command tells it to select files to delete based on an attribue (s in this case, which means system file).

Note: The \Low\History.IE5 directory will not be visible with the dir command unless you use dir /a. I'm mentioning this in case someone decides to look for it manually instead of copying the path from step 1.

share|improve this answer
1  
Some guy on Freenode was having troubles, and this solved his problem. Thanks! –  ekaj Apr 29 '12 at 19:34
add comment
  1. Close your browser and all other windows
  2. Reopen Internet Explorer
  3. Go to Tools->Internet Options->Advanced, and reset Internet Explorer settings by clicking on the reset button. Apply, OK
  4. You will get a box that states you must restart your computer. Shut down your computer, then restart.
share|improve this answer
add comment

I had the same problem. Try this:

  1. Tools;
  2. Explorer Bars;
  3. History.

    Hope that helps.

share|improve this answer
add comment

It seems that even if you don't have the "empty temporary Internet files on browser exit" checked in the advanced settings on your browser, there is also something unique on the security settings in internet explorer 9 called "protected mode" which seems to erase a lot of multimedia history. If you uncheck this box the browser will start to retain larger files like pictures and videos although it warns you that it "might put your computer at risk"

share|improve this answer
add comment

I found if you enable Delete Browser history on exit, close Internet Explorer, then re-open IE9 (and restore closed tabs), the history should start working again and you just disable Delete browser history on exit.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.