Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can consistently connect successfully to both the router and the internet using both my phone and two different computers which strongly suggests that the issue is at the desktop end.

Only my Windows 7 desktop machine has stopped getting internet connectivity. It manages to connect to the router's network using the Windows 7 wireless dialog, but can't access either the router configuration page (192.168.1.1) or the internet in general once connected. The strange thing is the wireless network icon in the notification bar shows a full strength signal, sometimes with the yellow warning triangle. The output of ipconfig /all is:

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix  . :
Description . . . . . . . . . . . : Broadcom 802.11g Network Adapter
Physical Address. . . . . . . . . : 00-12-17-94-98-90
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 192.168.1.102(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : 08 June 2011 10:32:16
Lease Expires . . . . . . . . . . : 08 June 2011 12:32:16
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 194.168.4.100
                                    194.168.8.100
NetBIOS over Tcpip. . . . . . . . : Enabled

I've tried

  • renewing DCHP settings
  • disabling IPv6
  • resetting TCP stack
  • uninstalling and reinstalling WLAN card drivers

I've not installed anything new or made any changes to my knowledge, this just happened out of the blue. The only possible change is my friend connected his macbook to the network, but that has gone now and shouldn't have any lasting effects? TCP/IPv4 is set to automatically find an IP address. Antivirus is MSE (up to date) and doesn't detect anything unusual. Any ideas where to go next? Any help is greatly appreciated.

For reference, the results of ipconfig /all on one of the working computers is:

Ethernet adapter Wireless Network Connection:

    Connection-specific DNS Suffix  . :
    Description . . . . . . . . . . . : Broadcom 802.11g Network Adapter
    Physical Address. . . . . . . . . : 00-16-CF-67-E5-97
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 192.168.1.100
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.1.1
    DHCP Server . . . . . . . . . . . : 192.168.1.1
    DNS Servers . . . . . . . . . . . : 194.168.4.100
                                        194.168.8.100
    Lease Obtained. . . . . . . . . . : 08 June 2011 10:26:38
    Lease Expires . . . . . . . . . . : 08 June 2011 12:26:38

UPDATE: Still not working, but I've managed to find a temporary workaround by tethering my Android phone, effectively becoming a new wifi adapter. Will be moving to a new flat so will test if it is a network specific thing - maybe the card has got damaged somehow? Also will see if the card is working with Linux soon.

share|improve this question
3  
Upvoted for well thought-out and asked question, with lots of relevant info. Especially impressive for a first question! (Sorry I can't actually be of any help, but thought this deserved mentioning.) –  Cam Jackson Jun 7 '11 at 23:43
2  
The DNS Servers look suspicous. Compare them to your other computers, are they set to automatic? Otherwise, you can try ping google.com and ping 8.8.8.8. –  Turbo J Jun 8 '11 at 0:33
add comment

4 Answers

The next few things I'd try (to see if I could get it working at all) based on info given:

  1. Right click the wireless icon and choose "Troubleshoot problems".
  2. Reboot.
  3. Hard-set it to a different IP address in the same subnet.

If one of these works and doesn't 'just fix it', it will hopefully at least lead you to the next steps you'll need to take (which would depend on the results of these tests).

Edit: Couple more

  1. Try Safe mode with networking
  2. Boot to another operating system (grab a Linux LiveCD or alike)
share|improve this answer
    
I set up the machine to have a static local IP (outside the range of normally allocated DCHP addresses) using the router's ip for the gateway, subnet of 255.255.255.0, and the DNS servers that have been confirmed to work on other machines in the network and this still doesn't work. Troubleshooting tries to reset the wireless adapter but this fails to restore connectivity. What I don't understand is why I can't even access the router's configuration page when Windows shows me to be connected to it's network... –  Hemmer Jun 8 '11 at 9:31
    
@Hemmer: Added a couple more :) –  techie007 Jun 8 '11 at 12:25
    
OK booted up in Safe Mode (with networking) and it still doesn't connect. Interestingly perhaps, when I run ipconfig /all, there is a Autoconfiguration IPv4 Address listed as 169.254.20.204(Preferred)? I will try and burn off a live CD and see if that provides any insight... –  Hemmer Jun 8 '11 at 13:28
    
Most routers (that I have seen) do not allow configuration when connected wirelessly, although there is usually an option to enable this. –  sgmoore Jun 8 '11 at 14:50
    
Yeah I've seen that before but this router does allow this, particuarly as I'm currently on the config page from my laptop (wirelessly)! –  Hemmer Jun 8 '11 at 14:54
show 1 more comment

Try a traceroute to your gateway, maybe routing somehow got misconfigured. Check the current route settings.

 tracert 192.168.1.1

 route print

See if the router configuration denies your preferred IP 192.168.1.102. See if your PCs MAC address is allowed on the router if the default is to deny any MAC address.

Some background: route, Default route, Default gateway

Update:

Found some additional ideas at another SU question: WiFi Network is fine for Macbook Pro and Win XP, but Win Vista "Limited Connectivity"

share|improve this answer
    
OK I've uploaded the results of the tracert, route print commands (as well as a recent ipconfig /all). I'm not familiar with the command though so I'm not certain how to interpret the results. The router does have the ability to filter mac addresses but that isn't set up. Also I'm not sure why it says "(Preferred)" when I have it set up to automatically find an IP? –  Hemmer Jun 8 '11 at 12:48
    
@Hemmer I am missing the route to the gateway (that should add by itself when connecting via wifi)You may only edit a comment every 5 seconds.(click on this box to dismiss). Couly you please try route add 0.0.0.0 0.0.0.0 192.168.1.1. That means: send all packets that are not local via 192.168.1.1 –  oleschri Jun 8 '11 at 13:07
    
@Hemmer Correction: route add 0.0.0.0 mask 0.0.0.0 192.168.1.1 - I don't do this too often ;) –  oleschri Jun 8 '11 at 13:13
    
When I enter the above command, it returns "The route addition failed: The object already exists." I should also note that running tracert seems to take about 10 mins or so, is this normal? –  Hemmer Jun 8 '11 at 14:02
    
@Hemmer that's really strange since the default route doesn't show up in route print. –  oleschri Jun 8 '11 at 14:31
show 4 more comments

I did an NSLOOKUP of several hosts I know using your DNS servers. They are refusing queries. You need to change your DNS servers. You can use Google's: 8.8.8.8 and 8.8.4.4

If you can ping them, you have Internet connectivity, and you just need to fix resolution.

share|improve this answer
    
Mm I looked up the connection information on both working (i.e. internet capable) computers and they both list DNS servers as: 194.168.4.100, 194.168.8.100. Both machines have no trouble pinging 8.8.8.8 (as the internet is working for them). –  Hemmer Jun 8 '11 at 9:25
    
Pinging 8.8.8.8 from the broken computer returns either: "Destination host unreachable" or "Request timed out". Pinging the router (192.168.1.1) returns the same. –  Hemmer Jun 8 '11 at 9:36
    
@Hemmer - 192.168.1.1 is a internal lan network ip address. 194.168.4.100 is also only an internal lan network ip address. I would make sure your router is using a working DNS server. I suggest switching to Google or OpenDNS. –  Ramhound Jun 8 '11 at 13:01
    
@Ramhound - I'm not sure I understand? I know the router (192.168.1.1) is a local address, I just wanted to demonstrate that it couldn't even connect to the router, let alone the internet. The DNS address appears to belong to Virgin, my current ISP and because this address works fine with the other machines, I'm cautious to believe that this is were the issue is. –  Hemmer Jun 8 '11 at 13:33
2  
@Ramhound if he cannot even ping the router by its IP then I doubt it's DNS related –  oleschri Jun 8 '11 at 13:38
show 1 more comment

I had the same problem in my laptop using Windows 7. I ran in recovery mode with network connection and it was able to access the router and internet.

Then, I rebooted to normal mode again and executed route add 0.0.0.0 mask 0.0.0.0 192.168.0.1 (my router IP) in a cmd with admin privileges and it said

"The route addition failed: The object already exists".

Right after that the warning icon in the wireless connection disappeared and now I have my router and internet connection again!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.