Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm looking for a way to remove embedded features from a PDF document. I recently purchased a Kindle DX. When I try to open some of my PDF files on the device, I get a message saying:

this pdf cannot be opened due to embedded features not yet supported by kindle

I'm looking for a way to remove the use of these features from the document so I can view it on my Kindle. I'm a Ubuntu Linux user. (I tried opening the PDF in Document Viewer and printing it to a PDF file by going to File->Print. This make it so I could open it on the Kindle DX, but the font is messed up and very difficult to read. This won't do.)

share|improve this question
Can you post a sample PDF? I'd like to know what kind of "embedded features" the Kindle might be talking about... – Kurt Pfeifle Jun 8 '11 at 18:58
up vote 2 down vote accepted

The solution is here:

sudo apt-get install pdftk
pdftk input.pdf output output.pdf

That will do the trick.

share|improve this answer
Mark didn't mention the problem was password-protection on his PDFs. – Kurt Pfeifle Jun 8 '11 at 18:59

@barbaz's brief answer worked for me. Here are the details on how I achieved success:

I downloaded from the SourceForge site and extracted the main folder in the zip to c:\qpdf on my Windows 7 box. I opened a Command Prompt in the bin directory and ran:

qpdf --decrypt infile.pdf outfile.pdf

My infile.pdf was over 4MB, full of fancy formatting and images. The document security properties displayed 'password security', not for opening but for changing, commenting, extracting. The document would not open on my standard Kindle.

The new outfile.pdf opened up in Acrobat and looks the same. The document security properties displays 'No Security', and more importantly, the new PDF opens on my Kindle after attaching the USB cable and copying the PDF to the Kindle's document directory.

share|improve this answer

To my experience you cannot remove restrictions with pdftk unless you know the password for the file.

qpdf --decrypt

should however be able to remove print/edit/copy-type restrictions.

share|improve this answer
Mark didn't mention the problem was password-protection on his PDFs. – Kurt Pfeifle Jun 8 '11 at 18:59
@pipitas Right, indeeed he doesn't want to remove restrictions but features. I was inspired by the URL of the 'High Tech Man' post :) – barbaz Jun 8 '11 at 19:17

You could try this Ghostscript commandline:

gs \
 -o kindle-ready.pdf \
 -sDEVICE=pdfwrite \
 -dPDFSETTINGS=/ebook \
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .