Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do you force reload (not from cache) in Firefox 4.0?

I have seen a lot of supposed theories on the internet, including:

Ctrl + F5

Ctrl + Shift + R

But, in reality, these do not actually work. So how do you really do it?

The only way I seem to be able to do it, is to manually clear the cache each time. This is hardly a solution in a development environment.

share|improve this question

migrated from Jun 8 '11 at 9:13

This question came from our site for professional and enthusiast programmers.

6 Answers 6

I'm on Firefox 8 and Ctrl + F5 definitely is the shortcut to a full page reload.

share|improve this answer
This also works for IE and I'm fairly certain Chrome as well. It's a reload bypassing the cache. –  UtahJarhead Oct 2 '12 at 19:09

In FireBug, on a Net tab open a menu (small triangle in the tab) and select Disable Browser Cache.

share|improve this answer

Go to the url address: about:config. This should load the Firefox config settings in the window for editing. You may see a warning message stating, "This might void your warranty!" that will require you to click through to load the settings. Then find the browser.cache.check_doc_frequency key and change it to 1.

For reference, valid values for browser.cache.check_doc_frequency are:

  • 0 – Check for a new version of a page once per session (a session starts when the first application window opens and ends when the last application window closes).

  • 1 - Check for a new version every time a page is loaded. ← This one

  • 2 – Never check for a new version – always load the page from cache. (offline mode?)

  • 3- Check for a new version when the page is out of date. (Default)

Obviously this will affect your entire browsing experience, but it's this or CTRL + F5 a few times.

share|improve this answer

As far as I know, at least in 3.x series, 2nd or 3rd refresh in a row forces Firefox to retrieve full page content again. I can agree that it seems like it is not always working.

share|improve this answer

You can also clear the entire cache if you want to. Just go to Options ► Advanced ► Network ► Cached Web Content ► Clear Now. Then click the usual refresh button or hit F5, and the page will be fully updated!

share|improve this answer
Thanks, works fine also with Firefox 37 –  markusN May 15 at 7:39

I've found that it can take up to 3 settings to make this work when dealing with inter-dependent Javascript files. The following works in FireFox 39 (and probably earlier versions as well):

  1. Open Firefox Developer Tools
  2. Click in the gear tab (right hand side, 4th from the right)
  3. Find the Advance Settings section (3rd column), and click on "Disable Cache (when toolbox is open)"
  4. Open a new tab and type about:config into the URL
  5. Search for "browser.cache.check_doc_frequency", and change its value to 1
  6. Search for "network.http.use-cache" and change its value to "false" by clicking on the line. Keep in mind for complex pages, this could significantly increase your time for page refresh.

Special thanks to the following for getting me on the right track:

Of course, if this is for more than just debugging and you want explicit control over the pages in production, you should do it in the page headers:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.