Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I copy VM's between harddrives and it never fails that the network adapter can't pick up an IP address when in Bridge mode. I always have to (ipconfig /release * /renew) to recover. No biggie.

This time however, I have copied top virtual machines (to separate external hard drives) and they will not bridge. They want to acquire an internal IP (169....). I have tried the following to no avail:

Within the Virtual Machine

  • Disabled/Renabled
  • Uninstalled / reinstalled
  • Uninstalled / reinstalled VMTools (wasn't sure if any of the network drivers were associated with VMTools
  • rebooted

From the Host

  • removed / added network adapter
  • From (Edit - Virtual Network settings) restored defaults
  • Made sure only physical network was connected (no wireless)
  • Rebooted
  • tried an assortment of settings for the bridged (replicate physical connection / or not)

The only way I can get the network connection to work is if I manually assign the IP/Gateway/DNS server.

Any suggestions?

share|improve this question
    
Did you look at the "Virtual Network Editor" for any weirdness? You can get to this through the "Edit" menu in VMware Workstation. – David Jun 8 '11 at 13:02
    
Yes, that was where I said I "Restored details". Just noticed that StackExchange brutalized my layout. – pghtech Jun 8 '11 at 13:25
    
Ahh... I see! Sorry about that. It all kind of ran together... lol... Good Job at fixing it @pghtech. I'm not sure of what to do now to fix your problem. Normally stuff just works. DHCP works just fine for me all the time, but then again, I am not moving my VMs between HDDs – David Jun 8 '11 at 14:00
    
Did you checked your DHCP server? – M'vy Jun 8 '11 at 14:20

Believe it or not, it turned out to be the DHCP server ran out of IP addy's.

share|improve this answer
1  
Heh - been caught by that myself! – Linker3000 Jun 8 '11 at 15:38
    
Maannnn, same issue here. After prompting the admin to check DHCP leases he found out we had many 'infinite' leases eating up the space. – Jan Doggen Mar 11 '15 at 14:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .