Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been making some changes to the .NET Framework on my system (I was trying to get Visual Studio 2003 to work, but that's another story), and I have now found myself in a position where I cannot turn Microsoft .NET Framework 3.5.1 back on.

So I am going to:

control panel>Programs and Features>Turn Windows Features on and off

Once the Windows features' screen has loaded, I go to the "Microsoft .NET v3.5.1" entry, tick the box and click "OK". It appears to be applying the change for a minute, then comes up with the following error:

An error has occurred. Not all of the features were successfully changed.

(Mmm. Helpful and descriptive! Thanks Microsoft!)

I've tried again with the .NET Framework 3.5 compact version installed and attempted to install .NET 3.5 SP1, but it wouldn't let me until I had turned this Windows feature on!

I'm really at my wits end with this. Where am I going wrong?

enter image description here

share|improve this question
1  
This fixed the problem: dllpurgatory.blogspot.com/2011/04/… However, if anyone wants to explain why it works, be my guest. –  Urbycoz Jun 8 '11 at 15:12
    
The page tells you why it works. I'm curious how it got broke. :-) –  afrazier Jun 8 '11 at 16:47
    
That's kinda what I mean. Why did it fix it for me? –  Urbycoz Jun 9 '11 at 8:04
    
I can't tell you how I did it. But I can tell you what I did. I uninstalled every version of .net framework, then reinstalled them- one by one. After installing 3.5 I tried to turn it on in windows features. Fail! –  Urbycoz Jun 9 '11 at 8:14
add comment

2 Answers

up vote 1 down vote accepted

Your question is ambiguous: In the title it says turn off, in the body, turn on: "Can't turn off Microsoft .NET Framework 3.5.1" and "I have now found myself in a position where I cannot turn Microsoft .NET Framework 3.5.1 back on."

If you are indeed trying to run it back on, I would just install .NET 3.5 and then the service pack from Microsoft Download Center:

share|improve this answer
    
You're right. Sorry. It was the title that was wrong. I can't turn it back "on". –  Urbycoz Jun 9 '11 at 7:19
    
I installed .net 3.5, but still same error. I tried to install the 3.5 sp1 but it wouldn't let me until I had turned this windows feature on. –  Urbycoz Jun 9 '11 at 7:20
    
Give this a try: support.microsoft.com/kb/306160 There is also the .NET cleanup tool: cid-27e6a35d1a492af7.skydrive.live.com/self.aspx/Blog_Tools/… –  KCotreau Jun 10 '11 at 4:37
    
Thanks KCotreau. They look useful. I can't really test them now though, since the problem has been resolved (see comment to my question). –  Urbycoz Jun 10 '11 at 7:23
add comment

x64 here, had same error, doing above (and using the x64 info), didn't work

then I remembered how to do a repair install when getting certain errors about being newer (win7)

dotNetFx35setup.exe /x to extract

expand to the extracted wcu folder set set compatibility mode to vista sp2, run as administrator

got somewhere, saw some error logs about moving the file to another drive was not possible (I have my docs mapped to another partition, same for apps64, as well as apps32)

I undid my mounts (other than docs), moved the wcu folder to c: drive, it started to install, but failed.

did a cleanup of .net using the tool.

used appwiz.cpl to reload .net 3.5

yay!

now I can move my files back to their partitions!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.