Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having problems setting the primary display in my Linux environment. I tried following the instructions here which seems to be working for everyone but it didn't work for me. In my /etc/gnome-settings-daemon/xrandr folder, I edited the monitors.xml file as well. It looks like this:

<monitors version="1">
  <configuration>
      <clone>no</clone>
      <output name="LVDS">
          <vendor>AUO</vendor>
          <product>0x22ec</product>
          <serial>0x00000000</serial>
          <width>1366</width>
          <height>768</height>
          <rate>60</rate>
          <x>1920</x>
          <y>0</y>
          <rotation>normal</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
          <primary>no</primary>
      </output>
      <output name="VGA-0">
              <vendor>DEL</vendor>
          <product>0xf022</product>
          <serial>0x30395453</serial>
          <width>1920</width>
          <height>1080</height>
          <rate>60</rate>
          <x>0</x>
          <y>0</y>
          <rotation>normal</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
          <primary>no</primary>
      </output>
      <output name="HDMI-0">
      </output>
  </configuration>
</monitors>

The settings seem correct, primary is set to yes on the monitor that I want but it doesn't seem to be working as well. Help please!!

share|improve this question

Try this command from a terminal (SUDO probably required):

xrandr --output VGA-0 --primary

There are several bugs filed regarding setting the primary display in Unity. Reading through the comments of this bug report may help you.

https://bugs.launchpad.net/ubuntu/+source/unity/+bug/742544

share|improve this answer
    
I've tried that already x_x – naithemilkman Jun 8 '11 at 14:55
1  
Setting the primary display on Unity being broken is a known issue. That's why there are several bugs filed about it on the Ubuntu bug tracking site (one of which I linked above). – bwall Jun 8 '11 at 15:02
up vote 0 down vote accepted

Someone I managed to get it to work by doing this:

xrandr --output VGA-0 --primary

Where VGA-0 is the monitor that you want to set to main. use xrandr to see your monitors

unity --replace &

Then I had to launch monitors (Alt-F2 -> Monitors) and click make default.

When I closed the terminal, everything disappeared. I had to force restart and when I booted in again, the launch bar was finally on the right side.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .