Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The past few days, my internet browsing has become very poor. It's not a matter of speed, as a speed test will give at least 15Mbps. It seems as if my laptop has a hard time actually connecting to the sites.

I've found a possible culprit, but don't know why it would affect anything:

Going to adapter settings and disabling ipv6, but leaving ipv4, my browsing is back to normal. Re-enabling ipv6 brings back the issue. This is strange though, because I have always had ipv6 enabled. Moreover, using sites to test ipv6 compatibility, I fail with ipv6 enabled on my adapter, and pass when it's disabled.

Ideas about why this is happening, and how to fix it?

share|improve this question
    
It might be wishful thinking, but could this be the culprit: is.gd/IIQWlf ? –  Teknophilia Jun 8 '11 at 15:59

5 Answers 5

up vote 2 down vote accepted

If you have IPV6 turned on, DNS lookups are 2 to 3 times slower than with IPV4. That's why it seems as if your computer has "trouble connecting" to web sites. When you initiate a connection to any site, the first thing it does is look up the IP address in DNS.

DNS lookups are slow on IPV6 for several reasons.

First, DNS is currently handled in serial, not parallel. The IPV4 lookup is always handled first, then the IPV6, so it takes at least twice as long.

Second, because the IPV6 lookups are less frequent, they are not cached as often on the DNS server, causing further delay.

This is what makes it seem like it takes sites longer to start loading when IPV6 is enabled, because they do take longer to start loading! Also, keep in mind that most web pages load content from many different URL's, and every time the browser has to look up an address for an image, Flash object, or anything else on the page, the slowdown on the page is increased.

There's nothing you can do in your operating system to speed this up. It affects all operating systems including Windows, Mac, and Linux

It's best to disable IPV6 for now, unless you have a specific requirement for it (almost no one does)

share|improve this answer
    
I am finding that DNS is almost as fast with IPv6. Especially when caching is on. The issues I am seeing are large amounts of retransmissions when links get saturated. I think the IPv6 retransmission times are much more aggressive and backoff much higher when one packet fails. For example, when our line is even slightly congested, google.com can take up to 10 seconds to load if even one packet is retransmitted. –  Brain2000 Aug 21 at 16:58

I am using IPv6 and it's true that some website are slower. I use Firefox and it seems that mostly website with https are infinitely long to load.

There is an option to use OCSP. When you disable it everything come back nearly as fast as it was. I strongly recommend to use IPv6 and start documenting the broken thing.

I pasted a capture here that shows how long the timeouts are with OCSP. Look at sequence 20:01:47.950204 and later.

In Firefox click on tools, options, then Advanced icon then encryption tab, then click on validation and uncheck OCSP and/or find a OCSP that is IPv6 aware.

share|improve this answer

You can try disabling the 'autotuning' function of win7 and vista in TCP/IP On command prompt you verify if 'autotuning' is on with

Netsh interface tcp show global 

if 'Receive Window Auto-Tuning Level' = normal then give the command:

Netsh interface tcp set global autotuning=disabled

The above fixed my sudden slow performance issues of win7 with ipv6 enabled.

share|improve this answer
    
I tried this but no dice. Thanks for answering such an old question though! –  Teknophilia Aug 14 '11 at 13:54

If you use VMware Workstation, when not working on any VM disable IP6 TCPIP connections used by VM's. Discovered on Windows 8.1 that leaving unused VMware IP6 connection enabled results in a parasite drag (PACKET CONFLICTS) thereby slowing web ISP speeds by 20% or more. Enable the IP6 network connection when you use VMware only. The wasted packets being siphoned off the ISP connection by the VMware IP6 connection were going to NUL while surfing the web not using VMware.

share|improve this answer

Just leave IPv6 disabled. You are not likely to use it for a while, and right now, your computer is looking for non-existent IPv6 things, especially DNS but possibly other things, and retrying them until they timeout. Those timeouts are what are slowing you down.

share|improve this answer
    
But I've had ipv6 enabled for quite some time, why would the issue begin now? Likewise, testing for ipv6 compatibility at several sites, I sometimes get that I'm compatible, and other times not. This goes along with the seemingly random ability to quickly connect to sites, and at other times, the slow resolution. –  Teknophilia Jun 8 '11 at 15:49
    
It could be something totally outside of your network...some change at your ISP, or along the route to a particular server. –  KCotreau Jun 8 '11 at 15:50
    
Other PC's on my network are fine, so it seems it's just my PC. –  Teknophilia Jun 8 '11 at 15:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.