Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Okay this is driving me nuts. I'm using Visio 2010 in a completely blank template. Here is what I'm doing:

  1. I'm drawing a simple rectangle
  2. I draw a second simple rectangle
  3. I'm trying to drag rectangle 1 over rectangle 2.

Every time I try to drag rectangle 1 over rectangle 2, the 1st rectangle snaps to some spot an inch or so away from the second rectangle. Basically, I can't place rectangle 1 over rectangle 2 at all, meaning I can't layer shapes at all.

What the heck is causing this idiotic behavior and how can I disable it?

share|improve this question
1  
Visio is not for painting, its for diagramming, so it never makes sense to do that in a diagram. – soandos Jun 8 '11 at 18:01
1  
You were able to do this in 2k7, why would they make such a big change in 2010? – Polaris878 Jun 8 '11 at 18:03
    
It works for me in 2010... – soandos Jun 8 '11 at 18:14
    
Thanks soandos, it seems then it is some sort of setting, but I can't seem to figure out what it is. – Polaris878 Jun 8 '11 at 18:29
    
I am guessing, but options->advanced->freeform settings? – soandos Jun 8 '11 at 18:30

What you want is Layout and Routing.

On the Design tab there is a section labeled Layout on the right.

In the bottom right corner of that section is a small box with an arrow, if you click that you will get to Layout and Routing , and on the bottom, under Other, uncheck Move other shapes away on drop.

You may also need to uncheck Enable connector splitting which is on the same tab.

share|improve this answer
2  
Un-checking this option doesn't prevent other shapes from moving-away... I want to overlap shapes. – PeterX Sep 25 '13 at 6:31
1  
This worked for me! Finally! Did I mention I HATE Visio! – Victor Grazi Jul 3 '14 at 18:30

@shimpossible's solution did not work for me.

However, that particular property seems to be tied to the document.

I use Visio to overlay images and was having the same issue using 2013 from a much older version of Visio. Solution was just opened a new "blank" document and then had no problem overlaying images (in this case pictures) one on top of another, or drawing over them.

It looks like the "diagram" option may also work, but I have not tried. Apparently it defaults to flow chart settings if you just open it up and it will not let you keep one image/shape over another.

share|improve this answer

The following works for Visio 2013 and I think 2010 works same way (but I don't have 2010 so can't be certain).

  1. Go to File-> Options-> Customize Ribbon and then enable/check the Developer tab.
  2. On Developer Menu, locate Behavior in the Shape Design group.
  3. From Behavior window, click Placement tab.
  4. From Placement tab, change Placement Behavior to "Do not lay out and route around.
  5. You may also need to set the dropdown "Move other shapes away on drop" to "Plow as page specifies". Review other checkboxes whether any apply to your objective.
share|improve this answer

The following solution works for 2013 and 2010 as well. I found this thread looking for the answer to a similar question (placing objects on top of lines - without them re-routing). I knew this could be done in Visio 2003 by a simple right click on the shape and changing the shape properties. But I could not find that in Visio 2010.

Go to File->Options->Customize Ribbon and then enable the Developer tap.

Now on the Developer Menu you should see Behaviour in the Shape Controls (2010) or Shape Design (2013) group. Use that to tinker with the properties. The one you are looking for is on the Placement tab. 1. Either under "Move other shapes away on drop", set it "Plow no shapes".
Or 2. Change Placement Behavior to "Do not lay out and route around".

This might be tedious if doing many layered shapes. For my original search (placing objects on top of lines - without them re-routing) set the Placement behaviour to: Do not lay out and route around. This will allow placing shapes on top others.

share|improve this answer

I had this same problem. While all of the above suggestions are helpful, so are these options which I discovered:

On the Home tab, under Arrange, make use of Bring to Front and Send to Back.

share|improve this answer
    
Not really relevant to the issue at hand. – Victor Grazi Jul 3 '14 at 18:26

I had the same frustrating issue with the grouped shapes in my diagram.

I have an old Visio 2003 but I fixed it by doing the following:

  1. Right-click shape
  2. Format > Behavior..
  3. Placement tab : Do not lay out and route around
share|improve this answer
    
This is identical to the highest upvoted answer. – Judith Mar 5 '15 at 19:41

The best solution I have found for this is to make a group of the elements that should be on top of another shape. Then cut (Ctrl+x) them from the page. After that create the shape that should be under the previously cut elements. Then paste (Ctrl+v) the elements on-top of the created shape.

share|improve this answer

Try locking the first rectangle. Right click on first rectangle, then select Container and then lock. Now you can drag any other object on the first rectangle at your desired position.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .