Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
Mac OS X Terminal not logging in

In short: Do I have any options other than restarting? Does anyone know a place with good documentation about the shell, specific to osx?


Longer version: My terminal has stopped working. I cannot write text, no anything. Suppose I could just restart the computer BUT that is not the point of my question. I want to learn more about my shell.

Suddenly my terminal cannot connect to my localhost. This is what happened. I used my terminal to edit text, then it shut itself off and now I can't get it working. I tried quiting it and restarting it, tried using the terminal from another account, same thing. Well. I suppose I can just restart my computer and everything will start working normally. Thing is, how fun is that?

So. What can I do to figure out what is wrong. And I know it would be much easier to do this if I had access to the terminal, but I don't, i.e. I cannot write in the terminal. At all.

(I am not that tech savvy. The most tech savvy things I can do is making web-pages and program in perl and scheme). Suggestions in which files to look for errors is much appriciated. If someone has a clue to where I can find documentation (readable for human beeings) about how the terminal connect to it's computers localhost that would also be appriciated.


Update: To clearify. Terminal starts. Then. I do not get a $. That is what the problem is about.

share|improve this question

marked as duplicate by Daniel Beck, Sathya Jun 9 '11 at 9:55

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
What do you mean with "shut itself off"? What happens when you open /Applications/Utilities/Terminal.app? Does the icon jump indefinitely, does a window open? Do you see the command line prompt? (Like Last login...). Does another Terminal like iTerm2 work? –  slhck Jun 8 '11 at 20:03
    
Consider telling us your version of Mac OS X. Also, open Applications/Utilities/Console.app and look for errors in the Console and system.log logs. Also, have you tired sending Reset/Hard Reset in Terminal? Are you even able to? –  Daniel Beck Jun 8 '11 at 20:04
    
In short. My terminal can't connect to my computers localhost. Running Snow leopard 10.6.7. I can open my terminal. But thats about it. Have tried 3 terminals (but not the X11 shell) same result. Terminal responds to text which shows on screen but is not responding to commands. Same when using another users account. –  r4. Jun 8 '11 at 20:21
    
How do you define "connect to localhost". Are you trying to ssh into your own computer? I mean, honestly, I'd just restart. If you can't reproduce the behavior it's not worth looking for the cause. –  slhck Jun 8 '11 at 20:30
    
"connect to localhost". One of my shells is zoc6. When zoc6 starts it says, connect to, localhost is the default. I let this question be up on superuser for an hour. Then I restart. –  r4. Jun 8 '11 at 20:38

1 Answer 1

up vote 1 down vote accepted

It seems like your ssh or telnet server on your local machine is no longer running. There was a change to how remote login worked in 10.0.1, but that was almost 10 years ago I think. More likely was Allow Remote Login got turned off in the sharing pane in Preferences.

However, you do not need to connect to localhost to get a terminal shell. Mac OS X contains a built-in terminal application known as, well, Terminal which will open up a command window and allow you to execute commands, no 'connecting' required.

If opening Terminal (in /Application/Utilities/) is not working for you, then what is not working about it? Does the application not load? Does it load, but the commands aren't working right? If that's the case, then what commands are you trying to execute, and what does it respond with?

share|improve this answer
    
I think you have to be more specific (perhaps in writing a longer answer). I did not change system preferences. All I did was editing files (in terminal) when terminal shut itself down. Terminal opens alright but it is not responding. –  r4. Jun 8 '11 at 21:13
    
To illustrate how my terminal behaves. Typing with the arrows, up, down, left, right. Then typing ctrl+c. RESULT. ^[[A^[[D^[[B^[[C ^C –  r4. Jun 8 '11 at 21:16
    
I'm really not clear when you say it opens but is not responding. Up above you said that you can type it, but not issue commands. So do you actually get a shell prompt? or is the shell prompt (the thing that ends with a $ where you type your commands) actually coming up? –  Kirk Jun 8 '11 at 21:19
    
What happens if you type reset (without the backticks) into the terminal and press enter? –  Kirk Jun 8 '11 at 21:20
    
It seems your emulator is simply echoing local keypresses. If you're talking about the Terminal application installed with OSX (and not your zoc6 terminal you mentioned earlier-- I'm still not sure which you mean when you respond to questions), then it likely means that Terminal can't open your shell (corrupt permissions or missing file) or that your shell is set to some weird program (I believe it should be bash, but I'm not 100% sure what OS X uses). –  Darth Android Jun 8 '11 at 21:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.