Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Adobe Photoshop CS2 Version 9.0.2 on Windows XP. I am having trouble exporting images from a psd file, because the colors in the resulting image are not the same as in the original file (fthe differences are obvious when opening with IrfanView or when I use them on my website). If I open the resulting image with Photoshop, than the colors match the original.

If this is of some help, the exported images have the same colors as when watching the original file with the Monitor RGB Proof Setup checked. (Menu View->Proof Setup->Monitor RGB), but they should look like when the option Windows RGB is checked.

I am a beginner in Photoshop and I couldn't find a solution for this problem. Even a simple copy-paste from the file causes the color change.

Could anyone give me some pointers on how I should make the export so that the colors don't change?

Thank you

share|improve this question
1  
This website is for programming related questions. You question may be better suited to doctype.com (CSS & design) or superuser.com (computer enthusiasts) –  bdukes Aug 25 '09 at 14:39
add comment

migrated from stackoverflow.com Aug 25 '09 at 15:00

This question came from our site for professional and enthusiast programmers.

6 Answers

It sounds like a Color Space issue. If you set up Photoshop for Print media, the default color space is CMYK, the standard for press and large scale printing. Computer monitors use a subset of the RGB color space called sRGB. When working with images for the web or desktop programs(even desktop printers for the most part), use the sRGB color space.

Converting completed images between the two often results in muddy, poorly saturated looking images. With the original open in Photoshop, you can change the color space without ill effect by going to the Image -> Mode. To make that setting the default color space, go to Edit -> Options, and its in there under color settings.

share|improve this answer
add comment

Is the original document in sRGB? If not try changing the profile and see how that works out. On a website it's a different issue again depending on whether or not the browser you use can read colour profiles or not (and you need to embed the profile when exporting the image to web which ads a couple of kbs to the filesize). Basically you can't really guarantee if people will see the colours you intended your images to have.

share|improve this answer
add comment

You might try changing the color profile.

Edit > Assign Profile... > Don't Color Manage This Document

share|improve this answer
add comment

I have tried all of your suggestions, but with no result. My original document is indeed sRGB.

I have switched to Photoshop CS4 and the problem is fixed in Firefox and IE6. The colors are almost the same as in the original, but the same images appear completely different in all the other browsers, including IE7 and IE8.

To obtain the above mentioned effect I used the images generated by the preview of the "Save for web & devices" menu. This way the colors are ok for FF and IE6. If I try to use "Save", "Save as" or any other method to save the images, the colors are messed up.

Thank you for your help

share|improve this answer
    
@Mihaela - your question isn't associated with your SU account (the name is grey and non-clickable, and your name on this answer isn't highlighted in blue). E-mail [email protected] and they'll associate it for you. I'll also flag the question –  ChrisF Aug 26 '09 at 11:49
    
@ChrisF - No need to e-mail the team. They can do this in the associations tab themselves. –  Diago Aug 26 '09 at 11:59
add comment

With the exception of FF 3.0 (when enabled), FF 3.5 and Safari, all browsers are not color managed. So you will see a difference between PS and the browser. That's how it's supposed to work. Have a read here: http://www.getcolormanaged.com/color-management/saveforweb/

share|improve this answer
add comment

You might want to check your view>proof setup

Make sure it is set to "Monitor RGB"

Then you will see the same colors as the export will be. You will probably have to adjust your colors, but now the exported images will look the same.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.