Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My IE9 (Win 7, 64bit) refuses to accept cookies from Intranet sites.

If I use the "full" name of the server, it will accept cookies.

For instance, if the server is called "server1" and has a full DNS name of "server1.internal.com", then IE9 ignores cookies from http://server1 but accepts them from http://server1.internal.com.

I've changed all the settings I can find to allow cookies, but it still fails.

When looking at any site on http://server1, the "Safety" / "Webpage privacy policy" dialog lists the current page on http://server1 and says that cookies are Blocked. Clicking on "Summary" opens a dialog where I can change it to say "Always allow this site to use cookies", but even though that is set, the browser STILL ignores the cookies!

Any ideas?

Updates, to respond to 3 comments

  • I can add the server name to "Trusted Sites" but it doesn't solve the problem.
  • In Security, Local Intranet, settings are at default
  • In Security, Local Intranet, Sites...
    • Automatically detect intranet network is checked.
    • I've added this server name to the list of web sites in the Advanced dialog

So far, nothing has worked. I am able to live with the issue because I can use the fully qualified name of the computer, and all is fine. And Chrome and Firefox have no problems...

share|improve this question
    
Can you add the short name to your Trusted Sites list? –  Steve Jun 10 '11 at 4:32
    
What happens if you set the security level back to default settings for Local Intranet? –  Steve Jun 10 '11 at 4:36
    
Also, review the sites listed in Local Intranet: s3.amazonaws.com/satisfaction-production/s3_images/310774/… –  Steve Jun 10 '11 at 4:38
    
Quick update... this problem still persists today! But since I can use the FQDN, and avoid using IE when possible, I can live with the issue. –  Glen Little Sep 20 '12 at 18:10
    
It must be something in Windows, because it has continued after installing IE10 and then installing IE11! –  Glen Little Nov 6 '13 at 16:26

3 Answers 3

I had his happen to me. My issue ended up that I was using an invalid character in my local fqdn.

In my case it was underscore.

www.website_dev.com

That name didn't allow cookies to work. When I changed the underscore to a hyphen everything was good.

share|improve this answer
    
Apparently IE is obeying the "LDH" rule. Namely DNS names should only contain "Letters, Digits and hyphen". tools.ietf.org/html/rfc3696 –  Peter McEvoy Apr 17 '12 at 15:01
    
+1 Greate Catch had the same problem, and the IIS error Message, was pretty cryptic. THX –  winner_joiner Jun 10 '13 at 6:54
    
I'm glad that this helped you... however, it doesn't reflect my problem. –  Glen Little Nov 6 '13 at 16:25

The "Automatically detect intranet network" does not work reliably. You would think drive mappings and especially GPO pushed drive mappings would be a decent hint that the remote machine is on the intranet, but no. It never works. Use Firefox or Chrome or open your "Internet Options" Local Intranet Security Tab on each machine and:

Uncheck "Automatically detect intranet network"
Check "Include all network paths (UNCs)"
Click "Advanced" and the URLs for the website.

share|improve this answer
    
Thanks, that sounded promising. I tried adding the URL to the list of websites in the Advanced dialog, but it has not made a difference. –  Glen Little Jun 17 '14 at 22:07

The registry value 1A0 under Trusted Zones by default is set at 1 per machine in the 32 and 64-bit hives in the registry and not defined per user, which means that Cookies are undefined in absence of other criteria as it is the case with the Internet Zone. The value of 1A0 should have the value 0 which was missed to be configured in the process of moving the Trusted Zone from the Medium Low Template to Medium few versions ago. So technically it is a Template miss. This is explained here http://blogs.msdn.com/b/ieinternals/archive/2010/06/05/understanding-internet-explorer-cookie-controls.aspx Interestingly, when IE7 reconfigured the Trusted Zone to use the Medium Security Settings template, the default for the URLAction in this zone was changed from Allow (0) to Evaluate P3P Policy (1). Unfortunately, there's no UI for configuring the P3P Policy for the Trusted Zone (oops!), so you may find that cookies are blocked for Trusted Sites by IE7 and later unless you change the Trusted Zone to use the Medium-Low template[2] which will Allow all cookies for the Trusted Site. So at a minimum you should set for Trusted Zone HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\2 value 1A10 to DWORD 0 Also check and set the Intranet Zone HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\1 value 1A10 to DWORD 0 You could go and set the correct values in the Template but as this involves changing values in the default installation of IE, I will not provide the configuration here, although I will mention that it would affact similar configuration on the global templates for IE.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.