Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Under Options -> General -> Startup, I have the action set to "Show my homepage".

However, every time I open up Firefox 4 it opens up my last session's tabs. I tried restarting, changing from "Show my homepage" to "Show my windows and tabs from last time" back to "Show my homepage" to see if maybe the option was just a little screwy, but I can't get it to stop opening up my previous tabs.

Is there another option I'm missing? I didn't have this problem with Firefox 3.6.

share|improve this question

3 Answers 3

Those options should work when Firefox ended cleanly last time.

I have had a similar issue, but when I restore the session, I end up in this loop. This it's down to Firefox re-opening the pages from before... including the one that killed it!!

Try "Start New Session", then when your home page is displayed, close Firefox.

See what happens when you start Firefox again... hopefully the error has been flushed, and the homepage is displayed?

share|improve this answer
    
Firefox is ending cleanly, so I don't get the Start New Session option when launching Firefox again. I tried just doing a normal exit from the Firefox menu (don't know if that does the same thing) but it didn't work. –  Brandon Jun 10 '11 at 17:37
up vote 2 down vote accepted

Well, now I feel silly.

I normally have a Firefox popup that streams a radio station. In Firefox 3.6, closing the main browser window and relaunching would start a new session regardless of the popup still being open or not.

In Firefox 4, having the popup window open keeps my session alive. Launching Firefox will keep launching my previous tabs until I close the popup.

share|improve this answer
    
Feel free to accept your own answer, it's actually a legitimate "solution" and I got hit by the same a few times (in the opposite way - I close the pop up after my other windows and then when I restart I lose all my tabs..) –  VPeric Jul 5 '11 at 18:53
    
@VPeric, thanks for reminding me. I had forgotten about this question. –  Brandon Jul 5 '11 at 19:22

If you want you can completely disable the session restore feature as described here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.