Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a Dell Latitude D420 laptop that hangs immediately after post with a blank screen and a blinking cursor in the upper left hand corner. It hangs long before Windows even begins to load. This behavior started after installing a new hard drive. The new hard drive does show up in the BIOS and displays the correct size.

The machine still boots up to the old (original) hard drive although that hard drive is failing and produces errors in the event viewer and performance issues.

I've tried reinstalling Windows on the new hard drive. It copies files to the new drive with no problem but then reboots and hangs.

I've also tried using Acronis TrueImage to copy an image of the original hard drive to the new hard drive. The image copies without a problem and all the files are readable on my desktop. However, the machine still hangs immediately after post. I even tried fixmbr and fixboot on it and it still hangs.

The original hard drive is a Toshiba MK3008GAL (HDD1642). The replacement drive I'm attempting to use is a Samsung HS040HB. Both of these drives work well on my desktop when connected to my ZIF-40 to USB enclosure/adapter.

Dell diagnostics doesn't find any problems when I run it with the new hard drive installed.

It looks to me like the new hard drive I got is just plain incompatible but is there some kind of BIOS setting that could possibly cause this early hanging problem?

share|improve this question
    
Did you try F8 > Safe Mode?, I would update the bios to the latest version available. –  Moab Jun 10 '11 at 21:34
    
It doesn't make it far enough to get to where the F8 key would do any good. I thought my post made that pretty clear. It's not a Windows boot issue. Updating the BIOS is probably the correct thing to do although my only option is to update it by booting up to a hard disk that is failing. I'm reluctant to do that. What if the BIOS firmware gets corrupt?! –  HK1 Jun 11 '11 at 2:01
    
Some older Dell bios can be flashed from a floppy or CD rom, you may have to make the floppy disc, then convert it to a bootable cd, flash from there....or use this method...biosflash.com/e/bios-boot-cd.htm –  Moab Jun 11 '11 at 3:10
    
Moab, there is one other problem. We're on BIOS A04. The current release is A06. If you review the notes on both A05 and A06, there are no hard disk or HD controller issues addressed in either one. –  HK1 Jun 11 '11 at 13:26
    
I never assume they post everything they fix or upgrade in a bios release. –  Moab Jun 11 '11 at 16:30

1 Answer 1

This is sort of an interesting problem:

Both 1.8" form factor hard drives are of the same type although different capacities and manufacturers. The original is 30G and the replacement is 40G.

What is interesting though is that the Dell spec sheet for that model 1.8" hdd lists the available hard drive type that come with that model laptop as capacities of 30, 60, 80GB

Since they actually lists specific hard drive sizes on the spec sheet, I'm inclined to wonder if the laptops BIOS on has settings for these three drive types as the only possible replacements types?

To verify that the laptop can handle other drive types like the one you are attempting to use, you might want to email Dell support possibly.

Kept researching for more info on this, and found that the available hard drive drivers under the driver downloads section from Dell for the Latitude D420 include drivers for 40G, 60G, and 80G

The link from Dell for this is: http://support.dell.com/support/downloads/driverslist.aspx?c=us&cs=555&l=en&s=biz&ServiceTag=&SystemID=LAT_PNT_PM_D420&os=WW1&osl=en&catid=&impid=

The same driver for all three drive types is R237954.exe

This driver description is dated 9/4/2009, ver 100-05, A00 and this driver is listed as being specifically for the Samsung brand of hard drives so maybe all you need to do is install this driver before cloning your old hard drive this way the new Samsung hard drive will already have the driver on the image when it boots.

share|improve this answer
    
Those are not drivers, but "firmware" that is intended to be flashed to the hard drive, and will not help this issue. –  Moab Jun 10 '11 at 21:34
    
Agree with Moab. They appear to be hard drive firmware updates. –  HK1 Jun 27 '11 at 22:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.