Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an add-on called Flash-Aid in Firefox 4 on my Ubuntu build, but ever since Mozilla came up with their new UI, I haven't been able to figure out how to get add-ons to actually run within Firefox. Double clicking them just opens up a detail page about them and there are no options to run them. With most add-ons, this isn't a problem since they usually don't need to be explicitly run, but this one does. Can someone tell me how to do this?

share|improve this question
    
Try dragging it into the browser? –  random Jun 11 '11 at 0:48

3 Answers 3

up vote 0 down vote accepted

It sounds like you've already managed to install the add-on, but don't know how to run it now that it's installed?

I don't have an Ubuntu build to verify this on, but in Windows, you can press Alt to bring up the traditional file menu, where you can click "Tools" and access the add-on menus where the add-on is usually launched from.

If alt doesn't work, click on the new Firefox button --> Options --> Menu Bar.

Another method: right-click on any toolbar, select customize, then drag the extension button to a toolbar. https://addons.mozilla.org/en-US/firefox/addon/flash-aid/reviews/291422/

share|improve this answer
1  
No need to do this. Firefox button -> Add-Ons, and switch to the Extensions tab. You'll have all the controls there you did in the FF3 Add-ons control panel. –  jcrawfordor Jun 11 '11 at 3:09
    
I put the add-on icon on the toolbar and was able to invoke the add-on from there. Thanks! –  efficiencyIsBliss Jun 12 '11 at 20:25

Note: This is a generic answer to allow adding 'incompatible' addons to firefox4.
I have not checked it for Flash-Aid (which is platform specific;
I am not on my Ubuntu machine at the moment to try this out).


To enable addons that were disabled when you upgraded to firefox 4,
you can turn-off the compatibility check as below.

  1. Type about:config into the address bar to reach firefox configurations.
    • you'll need to accept the warning about being careful to reach the config page
  2. In some white-space on that page, right-click and select New and Boolean.
  3. Now create a new entry with,
    • Name: extensions.checkCompatibility.4.0
    • Boolean value: false
  4. Now go to your addons page
    • you'll find that all the incompatible addons are re-enabled and would be active on browser restart
    • at this time, disable addons that you don't want
      (no value in starting all disabled addons that you might have there -- some might make firefox 4 unstable)
  5. When you are done, just restart the browser and all addons you left enabled will be active.

Update: for Firefox 5 you'd use extensions.checkCompatibility.5.0


There is also a Addon Compatibility reporter for alpha/beta users.

After installing the Add-on Compatibility Reporter, your incompatible extensions will become enabled for you to test whether they still work with the version of Firefox or Thunderbird that you're using. If you notice that one of your add-ons doesn't seem to be working the same way it did in previous versions of the application, just open the Add-ons Manager and click Compatibility next to that add-on to send a report to Mozilla.

share|improve this answer

You need to extract the xpi file and edit the install.rdf file then compress to zip and rename to .xpi, it should work with ff4.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.