Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've searched through the man pages several times for a way to set the length of time that status bar messages (what you see if you enter display-message "hello world" at a tmux command prompt) are visible, but there seems to be nothing. Does anyone know a way I can make them stay long enough to be read. Particularly annoying are error messages I get after entering a command with some syntax error. I have to repeat the command 3 or more times just to be able to get some idea what it says.

Does anyone know how to fix this? (Preferably without changing the source code and recompiling ;)

share|improve this question

2 Answers 2

up vote 8 down vote accepted

It sounds like you want to change the display-time session option. The initial default value is 750 milliseconds.

If you want to set a new, default value, then change the “global” value (e.g. in your .tmux.conf):

set-option -g display-time 4000

The global value will be effective for any sessions that have not established their own value (see below).

If you just want to change a single session (e.g. change only the current session, via a Prefix-: command line):

set-option display-time 4000

Of course (like any other tmux command), you can also make the changes from a shell command line:

tmux set-option -g display-time 4000
tmux set-option -t 4 display-time 10000  # set a value just for session "4"
share|improve this answer
    
Thanks! display-time wasn't in the PDF of the man pages I was using (on account of man pages not getting installed locally on my machine for some reason). –  iconoclast Jun 11 '11 at 19:41

There is also the show-messages command bound to ~ by default.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.