Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have WinXP install in virtualbox which host in Linux. I have a TP-Link (TP-WN321G) USB wifi adapter and have the driver installed inside WinXP. When I plug-in the wifi adapter, there is an option show "Ralink 802.11g WLAN [0101]" in the virtualbox's USB icon, tick on that option, the Device Manager able to detect the hardware which shows TP-Link, but when look into the properties, it says there is no driver was install.

I did try to install Ralink driver but still no luck. Just curious why my wifi adapter is TP-Link, but the option show Ralink?

May I know how can I emulate the wireless network inside WindowsXP?

share|improve this question
2  
Do you need wireless, or do you just want to connect to the network? –  Petah Jun 11 '11 at 9:18
    
It is not because of just want to connect to network, but I need it for my development where I am requested to have the wifi adapter present. Otherwise I must reformat my PC again to install the WinXP back. I can't do this cos I am using dual boot in my PC, it will overwrite my Linux boot sector. Any idea on this? –  huahsin68 Jun 11 '11 at 11:46
add comment

migrated from serverfault.com Jun 11 '11 at 8:58

This question came from our site for professional system and network administrators.

1 Answer

after you are able to view shared files from the host, automatically half or your problem is done. you only need to share the wireless or local network' internet ......and then restart you VM...Job done! worked for me , but do not forget to download (Oracle_VM_VirtualBox_Extension_Pack-4.0.8-71778.vbox-extpack) and install ,thats all! this is the link ""http://download.virtualbox.org/virtualbox/4.0.8/Oracle_VM_VirtualBox_Extension_Pack-4.0.8-71778.vbox-extpack""

share|improve this answer
    
I have installed the extension pack, and created new network that point to the TP-Link device under the Network Connection Window. Default it is disable as there was an existing network connection being connected. I disconnect the existing one, then enable back the TP-Link netowrk, but it failed to connect. May I know how can I check what cause this problem? –  huahsin68 Jun 26 '11 at 11:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.