Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I downloaded Cygwin, did something wrong, deleted it entirely, and reinstalled it.

Somehow I then did something very wrong with the result that I now have absolutely no permissions on any account to do anything to the .SSH folder, even though I'm the administrator. Here's everything I've tried but with no effect:

  1. Deleted the Cygwin .reg files
  2. Deleted all the Cygwin files that I could
  3. Gone to the Security tab and tried to change permissions from ANY account
  4. Tried deleting the folder using cmd
  5. Booted into safe mode and tried deleting from there

Any ideas how I can fix this?

share|improve this question
Are you able to take ownership of the folder? – bwDraco Jun 11 '11 at 17:02
I wish. Under the security tab, all of the options are grayed out. – Christian Jun 11 '11 at 17:04
Have you run CHKDSK on the volume? – bwDraco Jun 11 '11 at 17:05
Hmm I have not. How do I go about that? – Christian Jun 11 '11 at 17:07
@vorbis5: Are you sure you tried taking ownership? Or did you just try changing the permissions? The Ownership tab is in the Advanced dialog, separate from the Permissions tab. – Mehrdad Jun 11 '11 at 17:10
up vote 5 down vote accepted

I have a suspicion you were changing permissions with the Security dialog, rather than taking ownership, and that's why it didn't work (you weren't the owner).

Try this on the command line:


This will make the Administrators group the owners. (You can take off /A to make yourself the owner.)

share|improve this answer
perfect........ – Christian Jun 11 '11 at 17:29

try booting Ubuntu Live CD (or any Linux), and find the file in your hard disk, and delete...

share|improve this answer
Never used linux before. Is it possible to install linux and keep my windows 7? – Christian Jun 11 '11 at 17:12
You do not need to install Linux. Since this is a live CD, you can start Linux without making any changes to the system. While running the live CD, you can access the volume and remove the offending folder. Linux does not honor NTFS permissions, so if the filesystem isn't damaged, you should be able to remove it. – bwDraco Jun 11 '11 at 17:16
linux live cd don't need installation... u can run without install... only boot from ubuntu/linux cd... and select try... access your hard drive and find the file and delete – darkprop Jun 11 '11 at 17:18
Is this cd a physical cd? Because I don't have that. – Christian Jun 11 '11 at 17:21
I tried this. When I booted back to Windows, I had a .Trash-xxx folder instead at the same size of the deleted material, and which I still can not delete – erikric Jan 23 '12 at 21:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .