Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have OSX 10.5 and tried to sudo port install gnuplot, only to get this:

--->  Computing dependencies for gnuplot
--->  Verifying checksum(s) for gnuplot
Error: Checksum (md5) mismatch for gnuplot.pdf
Error: Checksum (sha1) mismatch for gnuplot.pdf
Error: Checksum (rmd160) mismatch for gnuplot.pdf

I don't care whether gnuplot.pdf has a checksum mismatch, it's not part of the executables... how do I get around this? I can't seem to re-download or uninstall either.

share|improve this question
See the MacPorts FAQ for some steps and notes about checksum mismatches. – slhck Jun 11 '11 at 23:01
up vote 1 down vote accepted

I did

sudo port -d selfupdate
sudo port clean gnuplot
sudo port install gnuplot

and that fixed it.

share|improve this answer
  1. First try @Jason's solution - updating that specific port may do the trick.
  2. Do a little bit of googling to understand why the checksum is failing.

The macports wiki lists common reasons for checksum failure and (in my personal experience) it is often a stealth upgrade by an upstream developer (like this one). If you have confirmed the cause of the checksum failure is benign you can override the macport checksum like this:

sudo port install gnuplot checksum.skip=yes

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.