Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been googling this issue for a long time, and no full solutions seem to be out there.

For certain mkv files, windows hangs when moving, copying, or deleting. These files play fine in a player such as GOM player.

System: a fast windows 7, 64 bit box.

Results:

  1. CPU change is negligible
  2. Memory usage rockets up to ~100%
  3. In cased of delete or move, "discovering files" dialogue box stays up for a long time
  4. Rename simply shows spinning icon until it finishes
  5. Action is completed after EXTREMELY long amount of time
  6. Memory usage does not return to normal

"Fixes:"

  1. Disable thumbnail creation (helps for some cases)
  2. After move/rename/delete kill explorer with taskmanager, and relaunch to re-claim your memory

Even with the thumbnails turned off, the issue persists. I have also tried re-muxing a file, which worked fine, but still resulted in a file with the same above issues.

share|improve this question
1  
Just sounds to me like the basic windows codec sets are having some issues reading the file. Usually for thumbnail creation, only the system embedded codecs are used, even if you have another application that can read the file, windows might have some issues. –  darkdragn Jun 12 '11 at 3:46
    
I agree with @Christopher Jackson. I've had this same issue a while back on my Windows XP machine and the culprit was a codec I installed. Uninstalling it fixed this. –  peter Jun 12 '11 at 4:20
    
Yes, this was an issue at one point, but I mentioned I have turned thumbnails off. I have no additional codec packs installed. Folders are "general" and in list view. There is no thumbs.db file (folder options: show hidden files, show system files) –  Creativehavoc Jun 12 '11 at 4:22
1  
Do you have DBPowerAmp converter installed? I found this exact problem because of the overlays that DBPowerAmp attempted to add to all MKV files (and others). Switching off the settings in DBPowerAmp sorted it for me. –  Shevek May 24 '12 at 13:11
add comment

5 Answers

It's DivX that's the problem!!! I've had this exact problem with a few MKV's that a friend gave me and it turns out DivX can't read something in the metadata (size, length, bitrate, etc) so it tries to read the whole file to find it. It will eventually finish but if you totally remove DivX Plus the problem will go away.

I use VLC or Hedia Player Classic HD anyway so this codec wasn't really needed - and it had horrid invasive services and updates so I am glad to be rid of it!

It took me a whole day of research to find this was the problem and removing DivX fixed it immediately for me!

share|improve this answer
    
Yes, it is DivX Plus and/or DivX Plus DirectShow filters. I had the same problem of Creativehavoc and Mike's answer was illuminating! No need to uninstall DivX Author or DivX converter if you have installed them on your computer. Many thanks Mike!! –  user126410 Apr 3 '12 at 17:52
add comment

The problem with some MKV files is the way they were encoded. Most MKV files are encoded using the mkvtoolnix program (MKVmerge and MKVExtract are part of this package). There is a setting in MKVmerge called "compression" that is selected by default while encoding. This option is selected for both the audio and video files inside the MKV fiel. This setting is in the program MKVmerge GUI, inside the Input tab, then inside the "Extra options" tab. You have to select "none" in the compression field for both the audio file (AC3, DTS, AAC, etc) and for the vidoe file (usually h264) while you are encoding (MUXING).

So, the only way to avoid your RAM to go up is to DEMUX the MKV file first (extract the H264 video file and audio files from the MKV file container using the MKVExtract GUI2 program) and then after MUX the MKV file back (putting the video and audio files inside the MKV container file using MKVmerge GUI program).

This new file won't have the issue of shooting your RAM up to the roof.

share|improve this answer
add comment

I can confirm that when I uninstalled k-lite codec pack full there was no change. I then uninstalled divx and now my problem has gone. Thanks to the above poster who said about the divx being the culprit; uninstalling the divx player did not help, I uninstalled the lot, did a reboot and it's perfect now.

share|improve this answer
add comment

You hit the nail on the head via the thumbnail creation symptom of this illness. You're probably not going to fix the problem unless you remove the one OS enhancement filter that K-Lite uses to create previews (or watever your codec-pack of choice is.) That some movies use different compression schemes can mean the erratic differences in slowdowns, and you've already noticed that different systems are now really nosy and can't just copy files and move files without slowing down to take a peek at them "usefully", to our general detriment.

I think there's also an Ff-mpeg or similar-sounding tool that automatically comes up on your system tray when you're decoding the movies, which includes doing some reading for explorer previews / thumbnails and metadata so that Windows can "helpfully" tell you about movie duration without double-clicking on it.

Again, Mkv files under windows are installed in your codec pack, so look in your start menu, run its config or setup.exe tool again and try to look for the option on filters (or even Add-Remove Programs and features control panel). You'll probably have no granular option to "remove" only MKV's filters, so perhaps you'll need to disable movie thumbnails for mp4 and other nifty filetypes.

I was lite on the details, so here's a google search, and one place where there's one thumbnail config tool, though it could conflict with your MKV pack already installed. Use at your own rick. Good luck

share|improve this answer
    
I don't actually have any codec packs installed. And I have turned thumbnail generation off. Folder-type is general, list-view. There is no thumbs.db file (show hidden files/system files) GOM player is used to watch the files. Currently all my "media related" installed programs are: Adobe Media Player, DivX, DTS+AC3 Filter, GOM Player, MKVtoolnix (just added to try re-muxing) –  Creativehavoc Jun 12 '11 at 4:20
add comment

Firstly, i'm unsure if this question, is actually a question... or just a discussion suited to forums

Secondly, if your question is, "what do I do when it hangs on deletion?"

1/ open the command prompt [Windows Key] -> cmd -> [Enter]

2/ navigate to the folder of the bad file

cd e:/Movies

3/ Prepare to delete the file but don't hit enter just yet!

del broken.mkv

REMEMBER: dont hit enter yet!

4/ [CTRL], [ALT], [DEL] open task manager, and quit "Explorer.exe"

5/ Run that 'delete' statement you had prepared in step 3

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.