Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My copy of Visual Studio seems to be set in "Always On Top" Mode. It runs this way by default; there seems to be no way of changing it.

Visual Studio runs as Administrator/Elevated, but that really shouldn't affect whether or not Visual Studio runs as "Always On Top."

Any idea why this may be occurring, and how to prevent it from happening?

share|improve this question
I saw a glimpse of this problem with Visual Studio 2010 starting to run "Always On Top" in Windows7, but it only happened straight upon a ReSharper update, and got resolved as soon as Visual Studio was restarted. – user157214 Sep 9 '12 at 9:43
Which version of Visual Studio do you refer to? – Marcel Dec 10 '13 at 10:18
Do you have ReSharper installed also? It seems to have a history of causing this type of issue on various versions. – panhandel Dec 31 '13 at 22:48
I was able to fix the problem with this: – enn Apr 27 '15 at 9:54
Simple restart of visual studio 2010 helped me also. – FrenkyB Nov 19 '15 at 11:18

I had a similar thing happen with Visual Studio being stuck as always on top. It started happening after I hit the Windows key followed by a bunch of arrow/home/end/pageup/pagedn keystrokes by accident (I had meant to use the control key).

What seemed to clear the always-on-top behavior was to select a different application (eg: Chrome), then press Windows-Home (which minimized everything other than Chrome), then press Window-Alt-Home. Then I could un-minimize Visual Studio, and it would no longer be always on top.

This worked with VS2010, VS2012 and VS2013 when they got into this weird always on top mode.

share|improve this answer
This work around didn't work for me. Windows-Alt-Home seems to just tell Chrome to go to the home page. Focusing on the desktop and Windows-Alt-Home didn't seem to work either. - I run VS2010 in Admin mode - Resharper - Windows 7 I don't have a solution, just giving feedback – David Chiew Feb 5 '15 at 22:35
This almost worked for me; I had to press Windows+Home (I didn't know about that one) and then simply pressed Windows+Home again. Windows+Alt+Home just sent my chrome to it's homepage. So: Windows+Home -> wait for the windows to come down -> Windows+Home -> Fixed! – Nebula Dec 10 '15 at 7:26

Perhaps an addin is causing it? Try disabling addins in Tools/Add-in manager then run Visual Studio in safe mode by executing

devenv.exe /safemode
share|improve this answer
this is the definitive answer imho. – nocarrier May 14 '14 at 1:46
works like a charm with after installing Resharper 8.2 ! – Guy Apr 29 '15 at 6:02

Use windowdetective to check if it's actually set to always ontop Work from there to determine the cause.

share|improve this answer

Maybe for some reason, the always-on-top property of your Visual Studio (VS) is being saved somewhere and then reloaded on run.
Depending on your VS version, you may be able to use FileBox eXtender(FBX) to change its always-on-top property for each run or permanently. It is probably better to use the version matching your Windows' architecture; 64-bit for x64 and 32-bit for x86. Also, FBX can probably be only used for elevated-mode programs if itself is run in elevated mode (e.g. "Run as Administrator").
Always-on-top status can be switched by clicking the pushpin on the program title bar when FileBox eXtender is running.

share|improve this answer

When I got this problem I found a solution to the reverse problem over at How-To Geek. Luckily it involved a TOGGLE which I could use to disable the always on top mode that Visual Studio's window had gotten into. As per the above link, I added this to my AutoHotkey script

^SPACE:: Winset, Alwaysontop, , A

and then I selected Visual Studio's window and used ctrl-space to toggle always on top. It worked like a charm.

share|improve this answer

Save your work, close Visual Studio, reopen it. Hit start, or debug, or hit F5.

This worked for me.

Very strange though, for months I didn't have this problem, and earlier when I started debugging, my window was behind Visual Studio's window... Thought it strange as it never happened before. Closed Visual Studio, reopened it, and viola.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.