Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My start menu has two entries for Firefox. I pinned Firefox to the start menu. One shortcut is from the C:\ProgramData\Microsoft\Windows\Start Menu\Programs folder, and the other from C:\Users\\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\StartMenu. I checked and both shortcuts have the exact same target ("C:\Program Files (x86)\Mozilla Firefox\firefox.exe").

These shouldn't show up twice. On another Windows 7 system, when I pin an item, it no longer appears in the other (recent) list. On this system however, it does.

If I unpin the pinned shortcut, it's gone and only the other icon appears. I only want the pinned version though.

Is there a way to stop both icons from showing up?

Screenshot of Issue

share|improve this question
add comment

3 Answers

1 is Pinned, 2 is "recently opened" and #2 list can vary depending on which program you use and how often.

.

enter image description here

Source of Information

share|improve this answer
    
It's worth noting that the behaviour observed is the effect of this Windows 7 change on this check for duplicates‌​. –  JdeBP Jun 13 '11 at 10:44
    
The problem I'm having is that both the pinned shortcut, and the regular shortcut is showing up in the menu. On my other Windows 7 system, when I pin something, it doesn't show up in the "recent" list anymore when pinned. –  nynexman4464 Jun 14 '11 at 14:09
add comment
up vote 1 down vote accepted

So I discovered what the issue was. I had done a fresh install of Windows 7, but copied my user folder from the old install. This included copying the C:\Users\<user>\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\StartMenu folder.

Although windows showed the "pinned" icons in my start menu, it didn't actually show them as pinned. When I went into that folder and deleted all of the shortcuts, the duplicate entries disappeared.

share|improve this answer
add comment

OK, I have going through this for years. When I add a shortcut link or an actual .exe - I only put it in one "startup" folder for only my "user account" and not in any other account. I also have checked this "Pinned" solution and the "recently opened" was not the problem.

Here is what I can add: 1. I have two two special programs that I want to start up automatically. The are very small and really can be considered a stand alone or portable program. - One is just a very simple desktop clock program. Not a Windows gadget. - Process Explorer is a "task manager replacement".

No matter what when I add these to the "Startup" directory two instances are going to be started.

Once I actually fixed this problem by mistake doing something else, so I have no idea what I did, but as luck would have it, before I had a change to follow up, I needed to do a restore from a backup so I went back to them starting twice and just did a manual kill after a restart.

I decided that research it more and I found out that if you look at this on the internet you find a alternative to using the "Startup" folder in Windows you can do it through the Windows Registry using "Regedit"

And this worked for me. Go to:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]

  1. Right click on "Run" on the left side of the screen and choose "New - String Value".

  2. Type in the name you want to call it. I want "Process Explorer" so I just called it "Process Explorer"

  3. Then I right clicked on my new "Process Explorer" now on the right and choose "Modify". Now it will ask you to enter a "Value data". Now you want to enter the path to the program you want to start.

  4. Please keep in mind that I am using (Win 7 64), and I put Processor Explorer in the 32 section of Windows 7 so mine will be located in C:\Program Files (x86).

  5. Here is what I entered in "Value Data": "C:\Program Files (x86)\ProcessExplorer\procexp64.exe" /t

(with the "" marks)

  1. That path is just when Windows can find the exe file I want to start. At the very end I have put " /t" Which tell Windows to start it minimized in the system tray. Don't add that if you don't want to start it minimized.

And it worked for me.

I have assumed several things in writing this and the most important is that you have a basic knowledge of modifying your windows registry. If you have never done a "regedit" or do not know what I am talking about here, don't do this. Modifying your windows registry and not knowing how to "undo" it is very dangerous.

Hope this helps,

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.