Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to scp files from a Linux box to a remote server, but after i put the root password for the server, it gives the message "Hello, I'm freeFTPd 1.0" I tried using put command but nothing is happening.. .. Any idea please

share|improve this question

migrated from stackoverflow.com Jun 12 '11 at 14:11

This question came from our site for professional and enthusiast programmers.

    
please show exactly what you're typing, and exactly what the response is. –  marto Jun 8 '11 at 21:01
    
[root@--]#scp (file name) admin@(remote server ip):/DATA The authenticity of host '(remote server ip)" cant be established. RSA key fingerprint is ----- Are you sure you want to continue connecting (yes/no)? yes Warning: Permanently added '(remote server ip)' (RSA) to the list of known hosts. root@(remote server ip)'s password: Hello, I'm freeFTPd 1.0 so what we do now????? –  user679095 Jun 8 '11 at 21:07
add comment

2 Answers

An FTP server is (unexpectedly) running on port 22, which is usually used for SSH. Find out the SSH port on the server. Then specify the port scp should connect to using the -P (uppercase P) command line option.

share|improve this answer
add comment

freeFTPd can also do sftp, but I'm not sure if it can scp.

What you're seeing is most likely the Greeting message file configured on the freeFPTd server. You can simply remove the Greeting message file. I'd also advise to try using sftp instead of scp.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.