Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed the VMware and the only option to log into the Virtual Machine is via the web interface. This way poses several uncomfortable moments:

  1. Need to enter the web-interface of VM infrastructure Web Access. As a part of the process, the browser tells me that the link (on localhost) is not trusted bla-bla-bla - need to "proceed anyway".
  2. Need to authenticate with login/pass.
  3. Need to open console from web-interface. The plugin that opens a console is an IE plugin only (neither Chrome, nor Firefox are supported).
  4. Finally, I am there and all is smooth and running.

All I am asking is kinda shortcut or at least a better way to reduce the 4 action items (described above) to 1 or 2. That would be terrific.

The screenshot might help: enter image description here

share|improve this question

2 Answers 2

up vote 5 down vote accepted

You can call the executable that is contained within this IE plugin directly from the command line. It opens up the VM window just as usual, but without the need to go through the browser or use another remote desktop solution. It's called vmware-vmrc.exe


Locating the vmrc Exectuable

In order to do all that, you need to find the vmware-vmrc.exe file.

  • If installed through IE, I guess it's in Application Data\VMware Remote Console (Web) or something like that.

  • If installed in Firefox, search the Firefox profile for the VMware extension. Never mind that it doesn't actually work in FF, you could also install the extension in Firefox 2.0 or something and then extract it from the profile folder there.

Once you have located the vmware-vmrc.exe file, place it somewhere in your PATH. Either just add the IE plugin folder or copy it. Important: If you copy it, you need the whole contents of this folder (all dll files and executables), not just the vmware-vmrc.exe file.

I 7zipped the whole thing for you to download in case you can't find it. Can't promise though that it's the latest version that works on all systems.

Once you have it in the PATH, you can call it from anywhere without having to specify the full path.


Using vmrc

Call it like this:

vmware-vmrc.exe -h 127.0.0.1:8333 -u <user> -p <password> "[standard] machinename/file.vmx"
  • -h 127.0.0.1 is the URL of your web interface, with the appropriate port. The neat thing is that this command also works over LAN and even over Internet, as long as the port is forwarded. That way you can access the virtual machines from outside.
  • -u <user> and -p <password> are the credentials you use to login there

  • "[standard] machinename/file.vmx" specifies your virtual machine (see below for more info).


How to find out the name of your VM

"standard" is the name of the default container. The following two depend on the name of your virtual machine. It's the one you find under "Target" in the web interface. The vmrun documentation has an explanation of that on page 7.

In your case, it should be named something like "[standard] Ubuntu 64bit/somefile.vmx"

To find out the real name of the VM, you can run the following command

vmrun -T server -h https://127.0.0.1:8333/sdk -u <username> -p <password> list

This will list all the VMs you have in the correct format for the above command to pass. In your case it will be something like "[standard] Ubuntu 64bit/something.vmx". The vmrun should be somewhere in C:\Program Files\VMware\VMware VIX.


Automating everything

You could place the vmware-vmrc.exe line in a .bat file and then just call the batch file to avoid having to type this all manually. For example, you can create batch files for single virtual machines and put them on your Desktop. Then, just double click the files and the virtual machine window opens.

share|improve this answer
    
You can edit deleted answers of yours and then undelete them. –  Daniel Beck Jun 13 '11 at 9:53
    
It's like I am almost there. The prog is in the PATH, but the VM is still not found (that's the error message I am getting). Added a screenshot of my Web UI (might help). Tried to execute the following code: vmware-vmrc.exe -h 127.0.0.1:8333 -u sasha -p mypass "[standard] sasha.com/Ubuntu 64bit.vmx". I've found the file under C:\Virtual Machines and the extension was vmxf (tried this one but with a little luck as well). –  BreakPhreak Jun 13 '11 at 12:38
1  
I updated my post above. You need to find the name of the vmx file, so it gives you something like Ubuntu 64bit/something.vmx. Your virtual machine has a folder name (which is "Ubuntu 64bit"), and inside that there's the vmx file you need to specify. –  slhck Jun 13 '11 at 13:29
1  
For completeness: superuser.com/questions/100249/… here is how to make the batch file pinnable on taskbar. The first answer worked for me :) Also, I've used start command, so that the cmd prompt will be closed and only the VM window will remain opened. –  BreakPhreak Jun 13 '11 at 14:55
1  
So did you manage to access the Virtual Machine now, using vmrc? Concerning the vmrun thing.. that's weird. It should work with the IP:port only. I know it works because I'm using it that way. –  slhck Jun 13 '11 at 15:02

Run a remote desktop server on your virtual machines and access the VMs using these (VNC for Linux, Screen Sharing/VNC for Mac OS X, Remote Desktop for Windows).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.