Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a server running SBS 2011, and we have a rotating disk backup solution using Comodo Backup. The backup is configured to back up to the H:, however, two of our five disks ALWAYS have a drive letter assignment of G. I have changed this in Disk Management numerous times, however, I am tired of having to do this every Tuesday and Friday.

How can I force Windows to assign specific drive letters to certain drives, or just force Windows to use the H: as the first attempted drive letter for all external media plugged into the server?

Thanks in advance for any assistance on this matter.

NOTE Tagged this with Windows Server 2008 R2 since SBS 2011 is essentially the same thing under the hood.

share|improve this question
    
It is better to manually assign a drive letter farther down the list, like R, once this is done for each device on each PC, windows will remember this and mount the drives as R each time they are plugged in. You would have to change Comodo setting. This usually solves problems of assigning drive letters when they are too close to other mounted drives. –  Moab Jun 13 '11 at 16:40

2 Answers 2

up vote 0 down vote accepted

I got around the issue by changing the drive letter that was referenced. I knew I could do this, but I had to change the reference in several places, so I was hoping I could just force the drive letter with a quick fix.

share|improve this answer

I usually do that:

  • plug in the drive
  • go to Device Manager (winkey+break > hardware > Device Manager)
  • remove it
  • unplug it
  • plug it in again: here Windows will reinstall drivers and will assign a available letter to it
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.