Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm receiving an error with my SSL connection. Using google chrome I see the following error:

Your connection is encrypted with 128-bit encryption ... however this page includes other resources which are not secure

I've scoured the source code, scripts and rendered code in the browser but cannot find where an http:// call is made. I've also used Fiddler2 to examine the traffic and everything is coming across via HTTPS. Has anyone run into this issue before and if so how did you go about finding the culprit.

The website is running ASP.NET MVC3 in C#. The page in question is a simple payment page. The only external call is the google analytics tracking code. The page appears to load correctly, all images and scripts are in place.

share|improve this question

migrated from stackoverflow.com Jun 13 '11 at 23:41

This question came from our site for professional and enthusiast programmers.

    
I had a similar issue with a page that used the google mapping API. Without more info on what you've got going on on that page I can't really come up with anything more concrete, though. –  kekekela Jun 13 '11 at 19:17
    
I'll tack on a bit more info –  Scott Vercuski Jun 13 '11 at 19:19
    
Maybe one of the HTTPS sessions is using a silly algorithm like DES or 64-bit RC4, neither of which I would call "secure" these days. –  sarnold Jun 13 '11 at 22:32

4 Answers 4

I had the same problem with Facebook badge, which under certain circumstances (I was logged in as a corporate page, not as a user) internally executed some javascript which accessed non-secure content. I discovered this only accidentally. When looking for solution I asked this question and got some useful answers (well, by that time I've discovered the solution but maybe they will help you).

share|improve this answer

Press Ctrl + Shift + J in Chrome and go to the network tab. In here it should show everything that passes through the browser, and will be a much better way of doing it than looking at the source code, etc.

share|improve this answer

The most likely cause is where an element (e.g an image) is being linked into the page and the link uses http instead of https

A good explanation can be found here.

http://ithemes.com/codex/page/Fix_Non-SSL_Elements_on_SSL_Page

share|improve this answer

You can use the HTTPS Switch Planner from the HTTPS everywhere addon. After you installed it, press CTRL+SHIFT+J and click on the HTTPS Switch Planner tab. There will be a list of resources that are loaded over HTTP.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.